<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>10207</bug_id>
          
          <creation_ts>2016-09-01 19:32:35 +0000</creation_ts>
          <short_desc>oe-selftest requires to document python-coverage requirements</short_desc>
          <delta_ts>2016-09-19 12:43:20 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>9</classification_id>
          <classification>Documentation</classification>
          <product>General Docs</product>
          <component>docs-general</component>
          <version>2.2</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>FIXED</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard>01 Sept 2016: NEEDINFO</status_whiteboard>
          <keywords></keywords>
          <priority>Medium</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>2.2 M4</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Humberto Ibarra">humberto.ibarra.lopez</reporter>
          <assigned_to name="Humberto Ibarra">humberto.ibarra.lopez</assigned_to>
          <cc>bluelightning</cc>
    
    <cc>leonardo.sandoval.gonzalez</cc>
    
    <cc>ross.burton</cc>
    
    <cc>srifenbark</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          
          <cf_docchange>No (bug/feature does not impact docs)</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>65717</commentid>
    <comment_count>0</comment_count>
    <who name="Humberto Ibarra">humberto.ibarra.lopez</who>
    <bug_when>2016-09-01 19:32:35 +0000</bug_when>
    <thetext>oe-selftest makes use of python-coverage to gather coverage on its files. There are cases when this tracking of coverage fails with earlier python-coverage versions due to bugs in the module. It should be mentioned somewhere that oe-selftest requires python-coverage 4.x or higher.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>65733</commentid>
    <comment_count>1</comment_count>
    <who name="Scott Rifenbark">srifenbark</who>
    <bug_when>2016-09-01 21:50:33 +0000</bug_when>
    <thetext>Hi, 

Thanks for noting this.  Right now, the only place we mention oe-selftest in the YP doc set is in the YP Reference Manual in the section that talks about required host packages (http://www.yoctoproject.org/docs/2.2/ref-manual/ref-manual.html#required-packages-for-the-host-development-system).  I have a separate section for the supported distros that list the packages required in order to run oe-selftest.  

I am not exactly sure what the top-end version of Python is that YP supports.  Right now we state that the user must have Python 2.7.3 (or higher) (see http://www.yoctoproject.org/docs/2.2/ref-manual/ref-manual.html#required-git-tar-and-python-versions).

I am guessing that maybe a simple note for each of the sections that say what packages you need for oe-selftest would suffice here?  Would that work?

Thanks,
Scott</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>65737</commentid>
    <comment_count>2</comment_count>
    <who name="Paul Eggleton">bluelightning</who>
    <bug_when>2016-09-01 21:55:55 +0000</bug_when>
    <thetext>The python version requirement will need updating for 2.2. Python 3.4.0 is the minimum version now.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>65741</commentid>
    <comment_count>3</comment_count>
    <who name="Scott Rifenbark">srifenbark</who>
    <bug_when>2016-09-01 22:02:27 +0000</bug_when>
    <thetext>Ok - Thanks Paul.

Three places exist where we talk about the minimum Python version needed.  I will fix them up.

Scott</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>65744</commentid>
    <comment_count>4</comment_count>
    <who name="Scott Rifenbark">srifenbark</who>
    <bug_when>2016-09-01 22:25:03 +0000</bug_when>
    <thetext>As an aside... I changed 4 locations to get the Python version requirements fixed.  However, I am still not sure if just providing a note in the oe-selftest sections for packages will satisfy this bug.

Here are the links for the minimum Python requirements:

 * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#the-linux-distro

 * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#required-git-tar-and-python-versions

 * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#var-PREFERRED_VERSION

 * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#faq (see Faq entry in section 31.4).

Scott</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>65927</commentid>
    <comment_count>5</comment_count>
    <who name="Leonardo Sandoval Gonzalez">leonardo.sandoval.gonzalez</who>
    <bug_when>2016-09-08 14:46:23 +0000</bug_when>
    <thetext>(In reply to comment #4)
&gt; As an aside... I changed 4 locations to get the Python version requirements
&gt; fixed.  However, I am still not sure if just providing a note in the
&gt; oe-selftest sections for packages will satisfy this bug.
&gt; 
Scott,

For the moment, I think we do not need to add any documentation regarding the python coverage library we are using and its version.

What we need to do this time is to check inside the code, this case oe-selftest, the coverage version and if requirement is not met, warn the user and quit, so this goes to Humberto instead of Paul.



&gt; Here are the links for the minimum Python requirements:
&gt; 
&gt;  *
&gt; http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#the-linux-
&gt; distro
&gt; 
&gt;  *
&gt; http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#required-
&gt; git-tar-and-python-versions
&gt; 
&gt;  *
&gt; http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#var-
&gt; PREFERRED_VERSION
&gt; 
&gt;  * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#faq
&gt; (see Faq entry in section 31.4).
&gt; 
&gt; Scott</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>66050</commentid>
    <comment_count>6</comment_count>
    <who name="Humberto Ibarra">humberto.ibarra.lopez</who>
    <bug_when>2016-09-12 20:30:25 +0000</bug_when>
    <thetext>Sent patch to check this in code.

http://lists.openembedded.org/pipermail/openembedded-core/2016-September/126435.html</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>66097</commentid>
    <comment_count>7</comment_count>
    <who name="Scott Rifenbark">srifenbark</who>
    <bug_when>2016-09-13 18:50:06 +0000</bug_when>
    <thetext>I am setting the doc flag to &quot;No&quot; based on Comment 5.  The manual is up-to-date regarding the minimal Python version needed for YP. 

thanks,
Scott</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>66313</commentid>
    <comment_count>8</comment_count>
    <who name="Ross Burton">ross.burton</who>
    <bug_when>2016-09-19 12:43:20 +0000</bug_when>
    <thetext>Fixed in oe-core a378b817504986173c4b0984a28aead247589b3f.</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>