<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>11722</bug_id>
          
          <creation_ts>2017-06-26 17:47:48 +0000</creation_ts>
          <short_desc>Error links broken on errors.yoctoproject.org for new cluster</short_desc>
          <delta_ts>2018-11-08 13:57:38 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>6</classification_id>
          <classification>Yocto Project Subprojects</classification>
          <product>Error Reporting tool</product>
          <component>Error Reporting Tool</component>
          <version>unspecified</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>FIXED</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>Medium</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>4.99</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Stephano Cetola">stephano</reporter>
          <assigned_to name="Michael Halstead">mhalstead</assigned_to>
          <cc>brian.avery</cc>
    
    <cc>infras.ab.watcher</cc>
    
    <cc>Infras.watcher</cc>
    
    <cc>joshuagloe</cc>
    
    <cc>mhalstead</cc>
    
    <cc>pidge</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          
          <cf_docchange>No (bug/feature does not impact docs)</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>74551</commentid>
    <comment_count>0</comment_count>
    <who name="Stephano Cetola">stephano</who>
    <bug_when>2017-06-26 17:47:48 +0000</bug_when>
    <thetext>The errors link to errors.yp.o on the new cluster doesn&apos;t work. The
reason is that errors.yp.o only recognises the old cluster as &quot;the
Autobuilder&quot; and therefore the autobuilder filter for the new cluster
doesn&apos;t return any results. The same query without the autobuilder
filter does return results.

  Unfortunately the errors.yp.o link in the yocto-autobuilder templates
is hard-coded, it would likely make yocto-autobuilder more useful for
non-upstream use if the errors instance were configurable. Then we
could add a configuration for the yocto.io cluster which works.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>77019</commentid>
    <comment_count>1</comment_count>
    <who name="Joshua Lock">joshuagloe</who>
    <bug_when>2017-09-21 14:43:33 +0000</bug_when>
    <thetext>We can resolve this by changing the submitter id&apos;s on both clusters to match the filter pattern. 

Currently yocto.io cluster submitter id&apos;s are of the form:
  yoctoio-autobuilder-$HOSTDISTRO 

and yoctoproject.org cluster submitter id&apos;s are of the form:
  production-yocto-autobuilder-$HOSTDISTRO

the error-report-web code filters submitter names that include &quot;yocto-autobuilder&quot;.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>82064</commentid>
    <comment_count>2</comment_count>
    <who name="Michael Halstead">mhalstead</who>
    <bug_when>2018-11-08 13:55:10 +0000</bug_when>
    <thetext>Links are working now so marking this resolved.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>82065</commentid>
    <comment_count>3</comment_count>
    <who name="Michael Halstead">mhalstead</who>
    <bug_when>2018-11-08 13:57:38 +0000</bug_when>
    <thetext>Pulled https://lists.yoctoproject.org/pipermail/yocto/2018-November/043203.html in on production to complete the fix.</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>