<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>1839</bug_id>
          
          <creation_ts>2011-12-15 11:57:26 +0000</creation_ts>
          <short_desc>mkdosfs fails for filesystems larger than 2GB</short_desc>
          <delta_ts>2012-01-12 09:33:56 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>7</classification_id>
          <classification>Build System, Metadata &amp; Runtime</classification>
          <product>OE-Core</product>
          <component>devtools / tool chain</component>
          <version>1.1</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>FIXED</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>Low</priority>
          <bug_severity>minor</bug_severity>
          <target_milestone>1.2</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Marc Ferland">marc.ferland</reporter>
          <assigned_to name="Nitin Kamble">nitin.a.kamble</assigned_to>
          <cc>jessica.zhang</cc>
    
    <cc>meta.mr.watcher</cc>
    
    <cc>meta.watcher</cc>
    
    <cc>sgw</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          
          <cf_docchange>---</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>17677</commentid>
    <comment_count>0</comment_count>
    <who name="Marc Ferland">marc.ferland</who>
    <bug_when>2011-12-15 11:57:26 +0000</bug_when>
    <thetext>I was building a development image which includes a lot of packages and the final hddimg failed with:

mkdosfs: seek failed
mkdosfs 2.10 (22 Sep 2003)
ERROR: Function &apos;build_boot_bin&apos; failed

Manually creating a 2GB filesystem works fine:
tmp/sysroots/x86_64-linux/usr/sbin/mkdosfs -C foo.img 2000000
mkdosfs 2.10 (22 Sep 2003)

Manually creating a 2.1GB filesystem fails with:
tmp/sysroots/x86_64-linux/usr/sbin/mkdosfs -C foo.img 2100000
mkdosfs 2.10 (22 Sep 2003)
mkdosfs: seek failed

So I guess the problem really is mkdosfs.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>17678</commentid>
    <comment_count>1</comment_count>
    <who name="Nitin Kamble">nitin.a.kamble</who>
    <bug_when>2011-12-15 12:01:41 +0000</bug_when>
    <thetext>The mkdosfs tool is a hacked up version to create efi partitions, 2gb or  more is too big dos fs for it to handle.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>18087</commentid>
    <comment_count>2</comment_count>
    <who name="Saul Wold">sgw</who>
    <bug_when>2012-01-11 15:25:15 +0000</bug_when>
    <thetext>I recently created a 3.5G mkdosfs, can you try again with the recent master, there were some fixes that where added, I was not able to make an dosfs greater than 4G, as Nitin point out this is primarily used for EFI boot creation.  Can you please confirm that you can&apos;t build an fs greater than 2G, also check you local fs to make sure oyu have space.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>18107</commentid>
    <comment_count>3</comment_count>
    <who name="Marc Ferland">marc.ferland</who>
    <bug_when>2012-01-12 09:16:15 +0000</bug_when>
    <thetext>I tested mkdosfs from poky master branch and it works as expected. I was able to create a file larger than 2GB.

Running the exact same command from the edison branch fails as described earlier. 

Problem solved!
Thanks!</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>18108</commentid>
    <comment_count>4</comment_count>
    <who name="Nitin Kamble">nitin.a.kamble</who>
    <bug_when>2012-01-12 09:33:56 +0000</bug_when>
    <thetext>I guess upgrade to the newer version has brought new features solving the 2GB barrier. Closing the bug now.</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>