<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>3751</bug_id>
          
          <creation_ts>2013-01-18 00:33:35 +0000</creation_ts>
          <short_desc>runqemu doesn&apos;t work on Fedora 17</short_desc>
          <delta_ts>2013-01-20 23:26:01 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>7</classification_id>
          <classification>Build System, Metadata &amp; Runtime</classification>
          <product>OE-Core</product>
          <component>virtual machines</component>
          <version>unspecified</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>WORKSFORME</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>Undecided</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>---</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Tom Zanussi">tom.zanussi</reporter>
          <assigned_to name="Richard Purdie">richard.purdie</assigned_to>
          <cc>Qi.Chen</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          
          <cf_docchange>---</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>28924</commentid>
    <comment_count>0</comment_count>
    <who name="Tom Zanussi">tom.zanussi</who>
    <bug_when>2013-01-18 00:33:35 +0000</bug_when>
    <thetext>With a scratch build of qemux86 sato poky/master commit: 64592f76264d8c1e590647a57e9c773edbf782e5

runqemu fails due apparently to some networking problem on Fedora 17, while the same commit works fine on Ubuntu 11.10:

[trz@empanada build]$ runqemu qemux86

Continuing with the following parameters:
KERNEL: [/home/trz/yocto/qemu-test/build/tmp/deploy/images/bzImage-qemux86.bin]
ROOTFS: [/home/trz/yocto/qemu-test/build/tmp/deploy/images/core-image-sato-qemux86.ext3]
FSTYPE: [ext3]
Acquiring lockfile for tap0...
Using preconfigured tap device &apos;tap0&apos;
WARNING: distccd not present, no distcc support loaded.
Running qemu-system-i386...
/home/trz/yocto/qemu-test/build/tmp/sysroots/x86_64-linux/usr/bin/qemu-system-i386 -kernel /home/trz/yocto/qemu-test/build/tmp/deploy/images/bzImage-qemux86.bin -net nic,vlan=0 -net tap,vlan=0,ifname=tap0,script=no,downscript=no -hda /home/trz/yocto/qemu-test/build/tmp/deploy/images/core-image-sato-qemux86.ext3 -show-cursor -usb -usbdevice wacom-tablet -vga vmware -no-reboot -m 128 --append &quot;vga=0 root=/dev/hda rw mem=128M ip=192.168.7.2::192.168.7.1:255.255.255.0 oprofile.timer=1 &quot;
qemu-system-i386: -net tap,vlan=0,ifname=tap0,script=no,downscript=no: could not configure /dev/net/tun (tap0): Permission denied
qemu-system-i386: -net tap,vlan=0,ifname=tap0,script=no,downscript=no: Device &apos;tap&apos; could not be initialized
[sudo] password for trz: 
Releasing lockfile of preconfigured tap device &apos;tap0&apos;</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>28935</commentid>
    <comment_count>1</comment_count>
    <who name="Chen Qi">Qi.Chen</who>
    <bug_when>2013-01-18 07:12:31 +0000</bug_when>
    <thetext>I once killed the &apos;runqemu&apos; process by a &apos;kill -9 xxx&apos; command, and next time I ran &apos;runqemu xxx&apos;, this error was encountered. 
After examining the scripts a little bit, I found that it was because that the cleanup function was not executed if the &apos;runqemu&apos; process was kill.
So I simply rebooted it, and everything was OK.

Is it the same case with yours?

Maybe we could add a &apos;clean&apos; option to runqemu to force it do cleanup, something like &apos;runqemu clean&apos;. 
In this way, we can correctly do some cleanup in case the &apos;runqemu&apos; process is killed by accident.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>28949</commentid>
    <comment_count>2</comment_count>
    <who name="Tom Zanussi">tom.zanussi</who>
    <bug_when>2013-01-18 15:44:10 +0000</bug_when>
    <thetext>In my case, the process was never killed - the failures I see always happen are first runs.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>28969</commentid>
    <comment_count>3</comment_count>
    <who name="Tom Zanussi">tom.zanussi</who>
    <bug_when>2013-01-20 23:26:01 +0000</bug_when>
    <thetext>I&apos;m quite sure I never killed the runqemu process to cause this.  Nonetheless I don&apos;t see the problem after a fresh reboot, and Saul can&apos;t reproduce it on Fedora18.

So I&apos;m closing this as not reproducible at the moment.</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>