<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>4222</bug_id>
          
          <creation_ts>2013-04-08 10:21:36 +0000</creation_ts>
          <short_desc>/etc/rpm-postinsts/rpm-postinsts failed</short_desc>
          <delta_ts>2013-04-12 10:14:51 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>7</classification_id>
          <classification>Build System, Metadata &amp; Runtime</classification>
          <product>OE-Core</product>
          <component>core</component>
          <version>1.4</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>VERIFIED</bug_status>
          <resolution>FIXED</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>High</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>1.4 M6</target_milestone>
          
          <blocked>4203</blocked>
          <everconfirmed>1</everconfirmed>
          <reporter name="Alexandru Georgescu">alexandru.c.georgescu</reporter>
          <assigned_to name="Ross Burton">ross.burton</assigned_to>
          <cc>bluelightning</cc>
    
    <cc>jessica.zhang</cc>
    
    <cc>meta.mr.watcher</cc>
    
    <cc>meta.watcher</cc>
    
    <cc>Qi.Chen</cc>
    
    <cc>radu.moisan</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          
          <cf_docchange>---</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>31665</commentid>
    <comment_count>0</comment_count>
    <who name="Alexandru Georgescu">alexandru.c.georgescu</who>
    <bug_when>2013-04-08 10:21:36 +0000</bug_when>
    <thetext>Errors and warnings appear on a qemu-image-minimal on journalctl -b output on first boot:

poky:fe336b149552b1f4f24d979c40302653298b98cc


STEPS TO REPRODUCE:

1. prepare a core-image-minimal qemux86 image with systemd and boot it.
To prepare it add the following lines to local.conf

DISTRO_FEATURES_append = &quot; systemd&quot;
VIRTUAL-RUNTIME_init_manager = &quot;systemd&quot; 


2. Start the image
3. run:

# journalctl -b 

and search for warnings and errors

EXPECTED RESULTS:
3. no warnings and errors 

ACTUAL RESULTS:

The following errors appear:
Apr 08 09:40:49 qemux86 S98run-postinsts[61]: ERROR: postinst /etc/rpm-postinsts/rpm-postinsts failed.
Apr 08 09:40:51 qemux86 systemd-udevd[91]: error changing net interface name eth0 to enp0s3: Device or resource busy


The following warnings appear.

Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended
Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended


OTHER COMMENTS:

After reboot, only the following error appear:
Apr 08 09:40:51 qemux86 systemd-udevd[91]: error changing net interface name eth0 to enp0s3: Device or resource busy</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31757</commentid>
    <comment_count>1</comment_count>
    <who name="Ross Burton">ross.burton</who>
    <bug_when>2013-04-09 11:12:58 +0000</bug_when>
    <thetext>Apr 08 09:40:49 qemux86 S98run-postinsts[61]: ERROR: postinst /etc/rpm-postinsts/rpm-postinsts failed.

This is interesting.  Nothing to do with systemd though.  CCing Laurentiu who has looked at these in the past in case he has any thoughts.

Apr 08 09:40:51 qemux86 systemd-udevd[91]: error changing net interface name eth0 to enp0s3: Device or resource busy

You&apos;re running a qemu which boots with the network already up, so this is expected.

Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended
Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended

All of these are because it&apos;s a live image, and will be resolved once Darren&apos;s new mkfs code is integrated.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31763</commentid>
    <comment_count>2</comment_count>
    <who name="Alexandru Georgescu">alexandru.c.georgescu</who>
    <bug_when>2013-04-09 13:18:45 +0000</bug_when>
    <thetext>HI Ross,
for core-image-sato I have the following: 

root@qemux86:~# journalctl -b | grep -i error
Apr 08 10:55:34 qemux86 distccd[109]: (dcc_save_pid) ERROR: failed to open pid file: /var/run/distcc.pid: Permission denied
Apr 08 10:55:34 qemux86 irattach[126]: tcgetattr: Input/output error
Apr 08 10:55:34 qemux86 rpc.nfsd[124]: error starting threads: errno 38 (Function not implemented)
Apr 08 10:55:41 qemux86 xserver-nodm[95]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-01: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-02: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-03: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-04: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-05: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;preferences-desktop&apos; not present in theme
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;computer&apos; not present in theme
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;system-file-manager&apos; not present in theme
Apr 08 10:56:46 qemux86 dropbear[184]: Exit before auth: Error reading: Connection reset by peer
root@qemux86:~# journalctl -b | grep -i warning
Apr 08 10:55:33 qemux86 kernel: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 10:55:33 qemux86 kernel: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended
Apr 08 10:55:39 qemux86 kernel[89]: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended
Apr 08 10:55:39 qemux86 kernel[89]: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended
Apr 08 10:55:41 qemux86 xserver-nodm[95]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Apr 08 10:55:42 qemux86 xserver-nodm[95]: ** (matchbox-panel:180): WARNING **: No APM support
Apr 08 10:55:42 qemux86 xserver-nodm[95]: ** (matchbox-panel:180): WARNING **: Applet &quot;(null)&quot; does not export the &quot;mb_panel_applet_create&quot; symbol.
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-01: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-02: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-03: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-04: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-05: Fatal error reading PNG image file: Decompression error in IDAT
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;preferences-desktop&apos; not present in theme
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;computer&apos; not present in theme
Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon &apos;system-file-manager&apos; not present in theme
root@qemux86:~#

As I can see, there are some PNG image errors which are not so urgent, but there are others like 
ERROR: failed to open pid file: /var/run/distcc.pid: Permission denied</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31793</commentid>
    <comment_count>3</comment_count>
    <who name="Chen Qi">Qi.Chen</who>
    <bug_when>2013-04-10 07:59:34 +0000</bug_when>
    <thetext>For the rpm-postinst error, the root cause is in rpm-postinsts.bb.

It inherits update-rc.d, but it shouldn&apos;t.
(There&apos;s no rpm-postinsts under /etc/init.d directory, and the S98xxx will be deleted after first boot. So inheriting update-rc.d is not ont unnecessary but also wrong.)

I&apos;ll send out a patch to fix this rpm-postinst error.

//Chen Qi</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31829</commentid>
    <comment_count>4</comment_count>
    <who name="Paul Eggleton">bluelightning</who>
    <bug_when>2013-04-10 14:56:02 +0000</bug_when>
    <thetext>FYI, I already have a patch for this queued (along with some other fixes related to read-only-rootfs support).</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31837</commentid>
    <comment_count>5</comment_count>
    <who name="Paul Eggleton">bluelightning</who>
    <bug_when>2013-04-10 15:45:24 +0000</bug_when>
    <thetext>There is now a patch for the rpm-postinsts issue:

http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/038201.html</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>31892</commentid>
    <comment_count>6</comment_count>
    <who name="Ross Burton">ross.burton</who>
    <bug_when>2013-04-11 10:22:14 +0000</bug_when>
    <thetext>Appeared to be fixed in today&apos;s build.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>32032</commentid>
    <comment_count>7</comment_count>
    <who name="Alexandru Georgescu">alexandru.c.georgescu</who>
    <bug_when>2013-04-12 08:41:11 +0000</bug_when>
    <thetext>will verify today</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>32043</commentid>
    <comment_count>8</comment_count>
    <who name="Alexandru Georgescu">alexandru.c.georgescu</who>
    <bug_when>2013-04-12 10:14:51 +0000</bug_when>
    <thetext>verified with poky dylan dab237bc6a7679dfeaa981c14736aedc7b04ecb9</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>