<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<!DOCTYPE bugzilla SYSTEM "https://bugzilla.yoctoproject.org/page.cgi?id=bugzilla.dtd">

<bugzilla version="5.0.6"
          urlbase="https://bugzilla.yoctoproject.org/"
          
          maintainer="it-coreprojects-helpdesk@linuxfoundation.org"
>

    <bug>
          <bug_id>539</bug_id>
          
          <creation_ts>2010-11-16 19:32:28 +0000</creation_ts>
          <short_desc>rpm version compare works incorrectly</short_desc>
          <delta_ts>2010-12-21 06:07:21 +0000</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>7</classification_id>
          <classification>Build System, Metadata &amp; Runtime</classification>
          <product>Meta-yocto</product>
          <component>meta-yocto</component>
          <version>unspecified</version>
          <rep_platform>x86</rep_platform>
          <op_sys>Multiple</op_sys>
          <bug_status>VERIFIED</bug_status>
          <resolution>WONTFIX</resolution>
          
          
          <bug_file_loc></bug_file_loc>
          <status_whiteboard></status_whiteboard>
          <keywords></keywords>
          <priority>Undecided</priority>
          <bug_severity>normal</bug_severity>
          <target_milestone>---</target_milestone>
          
          
          <everconfirmed>1</everconfirmed>
          <reporter name="Ke Yu">ke.yu</reporter>
          <assigned_to name="Saul Wold">sgw</assigned_to>
          <cc>kevin.tian</cc>
    
    <cc>n3npq</cc>
    
    <cc>poky.bs.watcher</cc>
    
    <cc>poky.watcher</cc>
    
    <cc>richard.purdie</cc>
    
    <cc>sgw</cc>
          
          
          <cf_os>---</cf_os>
          <cf_regression_type>---</cf_regression_type>
          <cf_verified>Program Management</cf_verified>
          <cf_docchange>---</cf_docchange>

      

      

      

          <comment_sort_order>oldest_to_newest</comment_sort_order>  
          <long_desc isprivate="0" >
    <commentid>10908</commentid>
    <comment_count>0</comment_count>
    <who name="Ke Yu">ke.yu</who>
    <bug_when>2010-11-16 19:32:28 +0000</bug_when>
    <thetext>When I upgrade cairo from 1.8.10 to 1.10.0, and doing poky-image-sato do_rootfs,  the zypper will report:

&quot;
| Processing zypper...
| error: Failed dependencies:
|       libcairo2 &gt;= 1.8.10 is needed by screenshot-0.0+svnr292-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by lttng-viewer-0.12.35-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by gtk+-2.20.1-r1.i586
|       libcairo2 &gt;= 1.8.10 is needed by pango-1.28.0-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by libowl0-0.0+svnr408-r6.i586
|       libcairo2 &gt;= 1.8.10 is needed by libfm-0.1.12-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by librsvg-2-2-2.26.3-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by libowl-av0-0.0+svnr398-r4.i586
|       libcairo2 &gt;= 1.8.10 is needed by libwebkitgtk-1.0-0-1.3.2+svnr62027-r0.i586
|       libcairo2 &gt;= 1.8.10 is needed by lttng-viewer-dev-0.12.35-r0.i586
|       libcairo-dev is needed by pango-dev-1.28.0-r0.i586
|       libcairo-dev is needed by gtk+-dev-2.20.1-r1.i586
&quot;

cairo 1.10.0 should actually meet the requirement of &gt;=1.8.10, so looks zypper does not correctly compare the version.

if i rebuild those recipes, i.e. increase the PR of the recipes (screenshot, lttng-viewer...) , and build again, the error disappear. the rpm spec becomes:  
Requires: cairo &gt;= 1.10.0

Reproduce step:
1. build poky-image-sato from scratch with poky 4.0
# git checkout laverne-4.0
# . poky-init-build-env
# bitbake poky-image-sato

2. apply the attached patch to upgrade cairo, and build poky-image-sato again
# patch -p1 &lt; cairo.patch
# bitbake poky-image-sato

3. the error will show out.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>10926</commentid>
    <comment_count>1</comment_count>
    <who name="Jeff Johnson">n3npq</who>
    <bug_when>2010-11-19 13:00:00 +0000</bug_when>
    <thetext>tracked at https://bugs.launchpad.net/rpm/+bug/677641</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>10929</commentid>
    <comment_count>2</comment_count>
    <who name="Ke Yu">ke.yu</who>
    <bug_when>2010-11-21 03:00:28 +0000</bug_when>
    <thetext>Dig more and find this is not related to rpm/zypper. it is cairo upgration specific issue:

In cairo 1.8.10, it only contains library, so according to the Debian renaming hook, the package is renamed to libcairo2. the generated rpm is libcairo2-1.8.10-r0.i586.rpm 

when upgrade to cairo 1.10.0, it also has bin executable, so the package name becomes cairo. the generated rpm is cairo-1.10.0-r0.i586.rpm.

in this case, those packages (e.g. screenshot) which depend on libcairo2-1.8.10-r0.i586.rpm can not find libcairo-1.10.0-r0.i586.rpm, and reports dependency failure.

I will update the cairo patch to specifiy the package name as libcairo2 to fix this issue.</thetext>
  </long_desc><long_desc isprivate="0" >
    <commentid>11095</commentid>
    <comment_count>3</comment_count>
    <who name="Ke Yu">ke.yu</who>
    <bug_when>2010-12-13 01:02:23 +0000</bug_when>
    <thetext>verified</thetext>
  </long_desc>
      
      

    </bug>

</bugzilla>