| Summary: | oe-selftest requires to document python-coverage requirements | ||
|---|---|---|---|
| Product: | [Documentation] General Docs | Reporter: | Humberto Ibarra <humberto.ibarra.lopez> |
| Component: | docs-general | Assignee: | Humberto Ibarra <humberto.ibarra.lopez> |
| Status: | RESOLVED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium | CC: | bluelightning, leonardo.sandoval.gonzalez, ross.burton, srifenbark |
| Version: | 2.2 | ||
| Target Milestone: | 2.2 M4 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | 01 Sept 2016: NEEDINFO | ||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | No (bug/feature does not impact docs) | |
|
Description
Humberto Ibarra
2016-09-01 19:32:35 UTC
Hi, Thanks for noting this. Right now, the only place we mention oe-selftest in the YP doc set is in the YP Reference Manual in the section that talks about required host packages (http://www.yoctoproject.org/docs/2.2/ref-manual/ref-manual.html#required-packages-for-the-host-development-system). I have a separate section for the supported distros that list the packages required in order to run oe-selftest. I am not exactly sure what the top-end version of Python is that YP supports. Right now we state that the user must have Python 2.7.3 (or higher) (see http://www.yoctoproject.org/docs/2.2/ref-manual/ref-manual.html#required-git-tar-and-python-versions). I am guessing that maybe a simple note for each of the sections that say what packages you need for oe-selftest would suffice here? Would that work? Thanks, Scott The python version requirement will need updating for 2.2. Python 3.4.0 is the minimum version now. Ok - Thanks Paul. Three places exist where we talk about the minimum Python version needed. I will fix them up. Scott As an aside... I changed 4 locations to get the Python version requirements fixed. However, I am still not sure if just providing a note in the oe-selftest sections for packages will satisfy this bug. Here are the links for the minimum Python requirements: * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#the-linux-distro * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#required-git-tar-and-python-versions * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#var-PREFERRED_VERSION * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#faq (see Faq entry in section 31.4). Scott (In reply to comment #4) > As an aside... I changed 4 locations to get the Python version requirements > fixed. However, I am still not sure if just providing a note in the > oe-selftest sections for packages will satisfy this bug. > Scott, For the moment, I think we do not need to add any documentation regarding the python coverage library we are using and its version. What we need to do this time is to check inside the code, this case oe-selftest, the coverage version and if requirement is not met, warn the user and quit, so this goes to Humberto instead of Paul. > Here are the links for the minimum Python requirements: > > * > http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#the-linux- > distro > > * > http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#required- > git-tar-and-python-versions > > * > http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#var- > PREFERRED_VERSION > > * http://www.yoctoproject.org/docs/2.2/mega-manual/mega-manual.html#faq > (see Faq entry in section 31.4). > > Scott Sent patch to check this in code. http://lists.openembedded.org/pipermail/openembedded-core/2016-September/126435.html I am setting the doc flag to "No" based on Comment 5. The manual is up-to-date regarding the minimal Python version needed for YP. thanks, Scott Fixed in oe-core a378b817504986173c4b0984a28aead247589b3f. |