| Summary: | git server git.yoctoproject.org hung up unexpectedly after 1.00GiB | ||
|---|---|---|---|
| Product: | [Infrastructure] Website | Reporter: | stefan.herbrechtsmeier |
| Component: | web-content | Assignee: | Michael Halstead <mhalstead> |
| Status: | RESOLVED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium+ | CC: | jku, juro.bystricky, mhalstead, randy.macleod, ross.burton |
| Version: | unspecified | ||
| Target Milestone: | Q1 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | |||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | No (bug/feature does not impact docs) | |
|
Description
stefan.herbrechtsmeier
2017-09-05 06:43:25 UTC
I can reproduce this exact scenario. Moving to Michael. Moving the git infra to a new server and version today. This should resolve this issue as well as other recent issues. An update: $ git clone https://git.yoctoproject.org/git/linux-yocto-4.9 Cloning into 'linux-yocto-4.9'... remote: Counting objects: 5094727, done. remote: Compressing objects: 100% (765391/765391), done. fatal: The remote end hung up unexpectedly 1.00 GiB | 232.00 KiB/s fatal: early EOF fatal: index-pack failed Still fails. works for me (January 11, 2018) Yes, works for me too. Closing, the new infrastructure must have solved this. This is an intermittent failure and it seems to be fairly easy to reproduce so I'm re-opening the defect. First, this failed for me from our corporate network: $ git clone https://git.yoctoproject.org/git/linux-yocto-4.9 Cloning into 'linux-yocto-4.9'... remote: Counting objects: 5107273, done. remote: Compressing objects: 100% (770209/770209), done. fatal: The remote end hung up unexpectedly 1.00 GiB | 3.45 MiB/s fatal: early EOF fatal: index-pack failed $ echo $? 128 This was started when the bug was reviewed on the YP BZ call so we likely overloaded the server. I ran the clone again in case we were all testing at the same time and overloading the server and it worked the second time. I then ran a series of clones simultaneously, one from work (4 MB/sec) and one on a fast (30 MB/sec) cloud server. The cloud server always worked. My work clone succeeded the next time but then failed again at 1.0 GiB: $ git clone https://git.yoctoproject.org/git/linux-yocto-4.9 Cloning into 'linux-yocto-4.9'... remote: Counting objects: 5107273, done. remote: Compressing objects: 100% (770209/770209), done. fatal: The remote end hung up unexpectedly 1.00 GiB | 3.39 MiB/s fatal: early EOF fatal: index-pack failed $ echo $? 128 Could this be corporate firewall/filter problems? I'll ask our network admin if there are any firewall logs that look odd. I checked on Jan 11/12th and there were no local network issues. I suspect that it's just a load issue for the git server. Michael, let me know if that's something you know how to tune. If not, Konrad Scherer @WR can give you some tips. The upgrades in February fixed this in my testing. |