| Summary: | build failure with gcc-6.3.0: ./md-unwind-support.h:55:21: error: field 'uc' has incomplete type | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] OE-Core | Reporter: | Scott Branden <scott.branden> | ||||
| Component: | devtools / tool chain | Assignee: | Juro Bystricky <juro.bystricky> | ||||
| Status: | RESOLVED FIXED | QA Contact: | |||||
| Severity: | critical | ||||||
| Priority: | Medium | CC: | jon.richardson, meta.mr.watcher, meta.watcher, scott.branden | ||||
| Version: | 2.4 | ||||||
| Target Milestone: | 2.4 | ||||||
| Hardware: | x86 | ||||||
| OS: | arm64 | ||||||
| Whiteboard: | |||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||
| Verified: | Documentation change: | Don't know | |||||
| Attachments: |
|
||||||
|
Description
Scott Branden
2017-09-14 04:18:43 UTC
This worked fine 2.4 M2, fails with latest (In reply to comment #1) > This worked fine 2.4 M2, fails with latest Scott, does it still work with 2.4 M2 and not latest or it **used** to work fine with 2.4 M2 ? Can you please provide some additional info regarding your system: distro, gcc version, steps to reproduce, etc. Also, to satisfy my own curiosity, why do you actually use GCCVERSION = "6.3"? It is not the default value and it is quite conceivable gcc 6.3 support will be dropped from the release. Created attachment 4009 [details]
bitbake libgcc logfile failure
Hi Juro, I did some further investigation I bisected the issue. Things are broken in 2.4_M2 as well actually. They are fine in 2.4_M1 and earlier. Using git bisect and rebuilding I found the commit causing the failure is: glibc: Upgrade to 2.25.90 I am building for aarch64 To reproduce set: GCCVERSION = "6.3%" and do: bitbake libgcc log.do_compile attached. We need GCC 6.3 as some code doesn't work for 7.x compiler. And, certain programs have been tested against certain gcc versions. In fact, I need to revert the removal of GCC 5.4 locally for other projects as well. (In reply to comment #4) > Hi Juro, > > I did some further investigation I bisected the issue. Things are broken in > 2.4_M2 as well actually. They are fine in 2.4_M1 and earlier. > > Using git bisect and rebuilding I found the commit causing the failure is: > glibc: Upgrade to 2.25.90 > > I am building for aarch64 > > To reproduce set: GCCVERSION = "6.3%" > and do: > bitbake libgcc > > log.do_compile attached. > > > We need GCC 6.3 as some code doesn't work for 7.x compiler. And, certain > programs have been tested against certain gcc versions. In fact, I need to > revert the removal of GCC 5.4 locally for other projects as well. Thanks, I can reproduce the problem easily. I do have a patch that I am currently testing. sent patch to the mailing list: http://lists.openembedded.org/pipermail/openembedded-core/2017-September/142352.html I can confirm this fixes the build issues we are having with GCCVERSION = 6.3% patch merged with master: http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=c485df7dae7781ebf1f3b1525a6f6fc7fc99a18b |