Bug 12253

Summary: Guest VM has errors on tap cleaning
Product: [Yocto Project Subprojects] Patchwork/Patchtest Reporter: Leonardo Sandoval Gonzalez <leonardo.sandoval.gonzalez>
Component: PatchtestAssignee: Leonardo Sandoval Gonzalez <leonardo.sandoval.gonzalez>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: Medium+ CC: daniela.plascencia, mhalstead
Version: 2.5   
Target Milestone: 2.5 M3   
Hardware: x86   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: No (bug/feature does not impact docs)

Description Leonardo Sandoval Gonzalez 2017-10-19 15:39:54 UTC
On latest code from patchtest (which uses pyro branches) the following error is observed when machine is turnoff and runqemu is in the clean-up phase


--------log snippet ---------------
Traceback (most recent call last):
  File "/home/patchtest/patchtest-guest-v2/poky/scripts/runqemu", line 1238, in <module>
    ret = main()
  File "/home/patchtest/patchtest-guest-v2/poky/scripts/runqemu", line 1233, in main
    config.cleanup()
  File "/home/patchtest/patchtest-guest-v2/poky/scripts/runqemu", line 1146, in cleanup
    cmd = 'sudo %s %s %s' % (self.qemuifdown, self.tap, self.bindir_native)
AttributeError: 'BaseConfig' object has no attribute 'tap'
KERNEL: [tmp/deploy/images/qemux86-64/bzImage--4.9.49+git0+6acae6f720_480ee599fb-r0-qemux86-64-20171018160049.bin]
MACHINE: [qemux86-64]
FSTYPE: [ext4]
ROOTFS: [tmp/deploy/images/qemux86-64/core-image-patchtest-qemux86-64.ext4]
CONFFILE: [/home/patchtest/patchtest-guest-v2/poky/build/tmp/deploy/images/qemux86-64/core-image-patchtest-qemux86-64.qemuboot.conf]
--------log snippet ---------------
Comment 1 Daniela Plascencia 2017-11-30 20:52:12 UTC
Michael, please ping Leo about this issue.
Comment 2 Michael Halstead 2017-11-30 21:20:56 UTC
I believe we resolved this a few weeks back. Leo can you confirm?
Comment 3 Stephen K Jolley 2018-01-11 16:04:25 UTC
Leo, can you answer this?
Comment 4 Leonardo Sandoval Gonzalez 2018-01-11 16:15:48 UTC
permission issue is not seen anymore.