Bug 13341

Summary: Fields in orm_layer too small for URLs
Product: [Build System, Metadata & Runtime] Toaster Reporter: John Gorkos <jgorkos>
Component: toasterAssignee: David Reyna <david.reyna>
Status: RESOLVED WORKSFORME QA Contact: Toaster default assignee <toaster>
Severity: normal    
Priority: Medium CC: jessica.zhang, randy.macleod, stanciux.mihail
Version: 0.0.0   
Target Milestone: 4.3 M2   
Hardware: x86   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: Don't know

Description John Gorkos 2019-05-08 19:05:34 UTC
While installing Toaster "from scratch", during the 'checksettings' phase of the installation manual at step 6 of section 3.9.2, I'm seeing "data too long for column vcs_web_tree_base_url" errors during database population.  After altering the database fields in orm_layer from varchar(200) to varchar(400), I see this:

MariaDB [toaster_data]> select max(length(vcs_web_tree_base_url)) from orm_layer;
+------------------------------------+
| max(length(vcs_web_tree_base_url)) |
+------------------------------------+
|                                205 |
+------------------------------------+
1 row in set (0.001 sec)

MariaDB [toaster_data]> select max(length(vcs_web_file_base_url)) from orm_layer;
+------------------------------------+
| max(length(vcs_web_file_base_url)) |
+------------------------------------+
|                                205 |
+------------------------------------+
1 row in set (0.001 sec)

I'm also seeing other instances of columns being too small for the data:
Updating recipes 13%2019-05-08 10:55:18,691 WARNING Failed saving recipe (1406, "Data too long for column 'license' at row 1")
That appears to be in table orm_recipe, where license is varchar(200).
I'm wondering if just declaring these as "text" or "varchar" of undefined length would be a quick solution.
Comment 1 David Reyna 2023-07-27 09:17:24 UTC
Per Kieran McNulty (WInd River) "I can set up a production instance without raising the error. Used mysql. Although the checksettings command that is supposed to raise an error gives no output, which is suspicious, I can continue with the setup process fine."

David