| Summary: | [master-next] qemumips-lsb sytemd failure | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] OE-Core | Reporter: | Armin Kuster <akuster> | ||||
| Component: | core | Assignee: | Ross Burton <ross.burton> | ||||
| Status: | RESOLVED FIXED | QA Contact: | |||||
| Severity: | normal | ||||||
| Priority: | High | CC: | meta.mr.watcher, meta.watcher, randy.macleod, richard.purdie | ||||
| Version: | 3.0 | ||||||
| Target Milestone: | 2.8 M4 | ||||||
| Hardware: | x86 | ||||||
| OS: | Multiple | ||||||
| Whiteboard: | |||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||
| Verified: | Documentation change: | Don't know | |||||
| Attachments: |
|
||||||
|
Description
Armin Kuster
2019-09-07 21:54:34 UTC
There is no error there and just as it reports: 'timeout'. -- Logs begin at Wed 2019-09-11 07:52:05 UTC, end at Wed 2019-09-11 07:56:29 UTC. -- Sep 11 07:52:13 qemumips systemd[1]: Starting Rebuild Hardware Database... Sep 11 07:53:43 qemumips systemd[1]: systemd-hwdb-update.service: Start operation timed out. Terminating. Sep 11 07:53:43 qemumips systemd[1]: systemd-hwdb-update.service: Main process exited, code=killed, status=15/TERM Sep 11 07:53:43 qemumips systemd[1]: systemd-hwdb-update.service: Failed with result 'timeout'. Sep 11 07:53:43 qemumips systemd[1]: Failed to start Rebuild Hardware Database. There is only one time failure during about 20 times qemu boot. But when I use command 'stress' to produce high cpu load, it fails to start systemd-hwdb-update everytime. I suggest to add 'timeout' to exceptions in the test cases. seems mips is just slow. https://github.com/systemd/systemd/issues/13581 Patch on the list. Turns out we already generate the hwdb at rootfs time *and* have postinsts to do this after the event, so we just need to delete the service file like several other distros already do. |