| Summary: | some step fail for "No space left on device" when booting ramdisk | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Runtime] System Startup | Reporter: | niqingliang2003 <niqingliang2003> | ||||
| Component: | system-startup | Assignee: | Saul Wold <sgw> | ||||
| Status: | RESOLVED OBSOLETE | QA Contact: | |||||
| Severity: | normal | ||||||
| Priority: | Medium | CC: | jessica.zhang, kevin.tian, msm-oss, sgw | ||||
| Version: | unspecified | ||||||
| Target Milestone: | 1.2 M4 | ||||||
| Hardware: | mpc8315e-rdb | ||||||
| OS: | ppc | ||||||
| Whiteboard: | (1.2) | ||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||
| Verified: | Documentation change: | --- | |||||
| Attachments: |
|
||||||
I've seen simiiar issues: /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device Can you please provide more detailed information about what image you where attempting to build when you got the failure? Have you seen this problem again? (In reply to comment #2) > Can you please provide more detailed information about what image you where > attempting to build when you got the failure? Have you seen this problem > again? I'm seeing this on core-image-minimal on something close to edison 1.1.1: Starting Bootlog daemon: bootlogd: cannot allocate pseudo tty: No such file or directory bootlogd. tar: can't open '/etc/dev.tar': No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 40: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 25: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 25: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 52: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 25: /etc/volatile.cache: No space left on device /etc/rcS.d/S37populate-volatile.sh: line 25: /etc/volatile.cache: No space left on device Configuring network interfaces... ADDRCONF(NETDEV_UP): eth0: link is not ready udhcpc (v1.18.5) started Sending discover... Sending discover... Sending discover... No lease, failing done. Fri Jan 6 17:13:00 UTC 2012 Running postinst /etc/rpm-postinsts/sysvinit-inittab.sh... INIT: Entering runlevel: 5ostins Starting syslogd/klogd: done Stopping Bootlog daemon: bootlogd. After some further investigation, it looks like we are getting some package creep via RRECOMMENDS, udev is depending on pciutils and usbutils and then RRECOMMENDS the -id packages of these, since they are build they will be included even though we really dont want them! That's one example worth about 290K! That about 4% of the image size! Also the /lib/udev directory takes another ~600K or so Then the dev.tar, for udev-cache takes about 1 meg of space, we could incease the minimal size, but that's not the answer here. So just with udev alone we have close to 2M of space taken! More investigation is required on how to tone down udev's space in the minimal image. Seems to not be an issue any more, please reopen if this issue re-appears or create a new bug. |
Created attachment 261 [details] serial console boot log I'm using mpc8314, not original mpc8315, and using ext2.gz.u-boot (ramdisk). the bootargs has the '/dev/ram rw'. the error focused on: /etc/udhcpc.d/50default: line 63: /etc/resolv.conf: No space left on device after login, I can't find the file "/etc/resolv.conf", and can manual create it. I'm sure the disk space is enough. the rootfs is used 72%. after reconfigured busybox and rebuilded all, the problem disappeared, and I can't reproduce it.