Bug 15401

Summary: testimage fails with linux-yocto-tiny and poky/custom distro
Product: [Build System, Metadata & Runtime] OE-Core Reporter: kweihmann
Component: Scripts and ToolsAssignee: Ross Burton <ross.burton>
Status: RESOLVED NOTABUG QA Contact:
Severity: normal    
Priority: Medium+ CC: randy.macleod, ross.burton
Version: unspecified   
Target Milestone: 5.0 M4   
Hardware: x86   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: No (bug/feature does not impact docs)

Description kweihmann 2024-02-15 10:06:34 UTC
Using 

PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-tiny"

in combination with poky or a custom distro (everything but poky-tiny) results in
a not bootable qemu image.

Tested setup

MACHINE = qemuarm64
DISTRO = poky

PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-tiny"

bitbake core-image-minimal && bitbake core-image-minimal testimage

--------
Error from testimage run

[    0.396777] netconsole: network logging started
[    0.431873] Sending DHCP requests ., OK
[    0.440728] IP-Config: Got DHCP answer from 10.0.2.2, my address is 10.0.2.15
[    0.442005] IP-Config: Complete:
[    0.442561]      device=eth0, hwaddr=52:54:00:12:35:02, ipaddr=10.0.2.15, mask=255.255.255.0, gw=10.0.2.2
[    0.444344]      host=10.0.2.15, domain=, nis-domain=(none)
[    0.445194]      bootserver=10.0.2.2, rootserver=10.0.2.2, rootpath=
[    0.445245]      nameserver0=10.0.2.3
[    0.450137] clk: Disabling unused clocks
[    0.460883] List of all partitions:
[    0.461578] 0100            6144 ram0 
[    0.461613]  (driver?)
[    0.462619] fe00          519844 vda 
[    0.462650]  driver: virtio_blk
[    0.464035] No filesystem could mount root, tried: 
[    0.464061]  vfat
[    0.464384] 
[    0.464739] VFS: Unable to mount root fs on unknown-block(254,0)
[    0.465118] User configuration error - no valid root filesystem found
[    0.465629] Kernel panic - not syncing: Invalid configuration from end user prevents continuing
[    0.466326] SMP: stopping secondary CPUs
[    0.466928] Kernel Offset: disabled
[    0.467272] CPU features: 0x0,00000000,34000000,0000400b
[    0.467878] Memory Limit: 1024 MB
[    0.468411] ---[ end Kernel panic - not syncing: Invalid configuration from end user prevents continuing ]---

----

With linux-yocto everything works like expected
Comment 1 Randy MacLeod 2024-02-22 15:33:31 UTC
Ross, you were going to triage this bug report...
Comment 2 Ross Burton 2024-02-23 10:53:22 UTC
The tiny configuration of linux-yocto is an *example* of how to build a minimal system.  It's tightly coupled with poky-tiny, notably the list of file systems in the kernel are limited and it expects to be booted with an initramfs.

Basically, it's not expected that any of the -tiny pieces will 'just work' in isolation.