| Summary: | AB-INT: wayland-info: failed to create display: No such file or directory | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [QA/Testing] Functional (self) Testing | Reporter: | Mathieu Dubois-Briand <mathieu.dubois-briand> | ||||
| Component: | oe-selftest | Assignee: | Ross Burton <ross.burton> | ||||
| Status: | RESOLVED OBSOLETE | QA Contact: | |||||
| Severity: | normal | ||||||
| Priority: | Medium+ | CC: | randy.macleod | ||||
| Version: | unspecified | ||||||
| Target Milestone: | 6.0 M1 | ||||||
| Hardware: | x86 | ||||||
| OS: | Multiple | ||||||
| Whiteboard: | AB-INT | ||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||
| Verified: | Documentation change: | No (bug/feature does not impact docs) | |||||
| Attachments: |
|
||||||
|
Description
Mathieu Dubois-Briand
2025-12-10 13:01:07 UTC
oe-selftest-armhost ubuntu2404-vk-arm2 mathieu/master-next completed at 2025-12-10 11:14:58+00:00 https://autobuilder.yoctoproject.org/valkyrie/#/builders/23/builds/2949/steps/15/logs/stdio Created attachment 5159 [details]
qemu boot log
Attaching boot log, we have some seats errors in there:
^MINIT: Entering runlevel: 5
Configuring network interfaces... ip: RTNETLINK answers: File exists
Starting system message bus: dbus.
00:00:00.000 ESC[1;34m [9.1/seatd/seat.c:48] Created VT-bound seat seat0ESC[0m
00:00:00.000 ESC[1;34m [9.1/seatd/seatd.c:194] seatd startedESC[0m
Starting Dropbear SSH server: dropbear.
Starting rpcbind daemon...done.
Starting bluetooth: bluetoothd.
Starting syslogd/klogd: done
* Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon
...done.
00:00:01.293 ESC[1;34m [9.1/seatd/server.c:145] New client connected (pid: 351, uid: 1000, gid: 1000)ESC[0m
00:00:01.293 ESC[1;34m [9.1/seatd/seat.c:239] Added client 2 to seat0ESC[0m
00:00:01.354 ESC[1;34m [9.1/seatd/seat.c:563] Opened client 2 on seat0ESC[0m
00:00:01.364 ESC[1;34m [9.1/seatd/seat.c:606] Disabling client 2 on seat0ESC[0m
00:00:01.382 ESC[1;31m [9.1/seatd/seat.c:327] Could open device: client is not activeESC[0m
00:00:01.390 ESC[1;31m [9.1/seatd/client.c:229] Could not open device: Operation not permittedESC[0m
00:00:01.391 ESC[1;34m [9.1/seatd/seat.c:158] No clients on seat0 to activateESC[0m
seatd: /usr/src/debug/seatd/0.9.1/common/terminal.c:136: get_tty_path: Assertion `tty >= 0' failed.
00:00:00.098 ESC[1;31m [9.1/libseat/backend/seatd.c:311] Could not poll connection: Broken pipeESC[0m
00:00:00.099 ESC[1;31m [9.1/libseat/backend/seatd.c:131] Invalid message: insufficient data receivedESC[0m
Internal warning: debug scope 'drm-backend' has not been destroyed.
Wondering if this is related to the systemd upgrade that just landed, which included a change to xserver-nodm to mitigate a device race... If we didn't see this since the initial report which was on master-next then I blame the systemd upgrade which wasn't complete. |