Bug 2226

Summary: Pseudo: open64 fails to set O_LARGEFILE in open call to host OS
Product: [Yocto Project Subprojects] Pseudo Reporter: Peter Kleiner <peter.kleiner>
Component: pseudoAssignee: Mark Hatle <mark.hatle>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: Medium CC: richard.purdie, seebs, yp.pseudo.watcher, yp.watcher
Version: unspecified   
Target Milestone: ---   
Hardware: x86   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: ---

Description Peter Kleiner 2012-04-02 09:10:26 UTC
Due to a bug in the mapping of open64 a regular open call is issued without O_LARGEFILE being added. This causes large file operations like dd to fail.

The bug is in pseudo-1.2/ports/linux/guts/open64.c where O_LARGEFILE is added to mode instead of flags
Comment 1 Mark Hatle 2012-04-04 17:41:02 UTC
I'm looking into this.
Comment 2 Mark Hatle 2012-04-04 17:45:44 UTC
This was fixed upstream:

http://git.yoctoproject.org/cgit/cgit.cgi/pseudo/commit/?id=9461b2a88ba672c533a331f95dd5ba7eba683c77

This is already in the latest (master) oe-core.
Comment 3 Mark Hatle 2012-04-04 17:46:42 UTC
Fixed upstream.