| Summary: | [Autobuilder] fri2-noemgd build failed on autobuilder due to stale NFS Handle | ||
|---|---|---|---|
| Product: | [Infrastructure] AutoBuilder | Reporter: | Andrei Dinu <andrei.adrianx.dinu> |
| Component: | autobuilder | Assignee: | Michael Halstead <mhalstead> |
| Status: | RESOLVED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium | CC: | elizabeth.flanagan, infras.ab.watcher, Infras.watcher, sgw |
| Version: | unspecified | ||
| Target Milestone: | 1.4 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | |||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | --- | |
|
Description
Andrei Dinu
2012-12-21 10:47:38 UTC
We've seen this before, generally during times of high network load. Reassigning to Michael Halstead to see if he has some ideas. It's a generally rare occurance. I do not see high network load on nas02. At this point I suspect this is related to the shortcomings of NFSv3. The nas01 is using NFSv4 and as far as I know we don't see these errors there. nas02 was switched to provide NFSv3 after it was upgraded to OpenSUSE 12.2 from Ubuntu 12.04LTS and idmapd failed to work correctly. Attempts to fix idmapd failed at the time. I need to schedule 3 hours of downtime for ab03, ab07, ab08, and ab09 in order to attempt to switch back to NFSv4 after applying all available updates. The relevant builders have been upgraded to openSUSE 12.2 and mounts have been switched to NFSv4. I expect this will fix the stale NFS handle problem. |