| Summary: | Runtime initialization error: Cannot create link over existing -/tmp-. | ||
|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] OE-Core | Reporter: | Saul Wold <sgw> |
| Component: | core | Assignee: | Chen Qi <Qi.Chen> |
| Status: | RESOLVED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium | CC: | meta.mr.watcher, meta.watcher, rjohnweber |
| Version: | 1.4 | ||
| Target Milestone: | 1.4 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | |||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | --- | |
|
Description
Saul Wold
2013-03-02 00:24:09 UTC
Also seen on Freescale ARM-based boards when building core-image-minimal, but I suspect I would see it on other image builds as well. Hi Saul, This error is caused by the changes introduced by the following commit. commit db5847dd411f12b8b96b9bee624e9be30b504653 Author: Chen Qi <Qi.Chen@windriver.com> Date: Thu Jan 24 15:28:45 2013 +0800 initscripts: let populate-volatile.sh create the /tmp link Previously, the /tmp link (/tmp -> /var/tmp) was created by the bootmisc.sh script. So in case of a read-only rootfs, this symlink would not be created correctly. The populate-volatile.sh script is intended to handle all directories and files related to volatile storage, so we should let it create the /tmp link. In addition, because of the improments of populate-volatile.sh, the data loss problem of bug#3404 is also resolved by this patch. And it will be gone if the populate-volatile.sh related patches are merged. For now, the populate-volatile.sh script doesn't handle link config items correctly, so if the target (in this case, /tmp) has already existed, the script will just skip this item, thus resulting /tmp->/var/tmp link not created. merged into poky/master: 297906d39cfcaa56009214e8759b9853f82f02d7 http://git.openembedded.org/?p=openembedded-core.git&a=commit;h=a54287d8e3d75a727c8ed5654a822bda256b0849 |