| Summary: | /etc/rpm-postinsts/rpm-postinsts failed | ||
|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] OE-Core | Reporter: | Alexandru Georgescu <alexandru.c.georgescu> |
| Component: | core | Assignee: | Ross Burton <ross.burton> |
| Status: | VERIFIED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | High | CC: | bluelightning, jessica.zhang, meta.mr.watcher, meta.watcher, Qi.Chen, radu.moisan |
| Version: | 1.4 | ||
| Target Milestone: | 1.4 M6 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | |||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | --- | |
| Bug Depends on: | |||
| Bug Blocks: | 4203 | ||
|
Description
Alexandru Georgescu
2013-04-08 10:21:36 UTC
Apr 08 09:40:49 qemux86 S98run-postinsts[61]: ERROR: postinst /etc/rpm-postinsts/rpm-postinsts failed. This is interesting. Nothing to do with systemd though. CCing Laurentiu who has looked at these in the past in case he has any thoughts. Apr 08 09:40:51 qemux86 systemd-udevd[91]: error changing net interface name eth0 to enp0s3: Device or resource busy You're running a qemu which boots with the network already up, so this is expected. Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended Apr 08 09:40:49 qemux86 kernel: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended Apr 08 09:41:03 qemux86 kernel[296]: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended All of these are because it's a live image, and will be resolved once Darren's new mkfs code is integrated. HI Ross, for core-image-sato I have the following: root@qemux86:~# journalctl -b | grep -i error Apr 08 10:55:34 qemux86 distccd[109]: (dcc_save_pid) ERROR: failed to open pid file: /var/run/distcc.pid: Permission denied Apr 08 10:55:34 qemux86 irattach[126]: tcgetattr: Input/output error Apr 08 10:55:34 qemux86 rpc.nfsd[124]: error starting threads: errno 38 (Function not implemented) Apr 08 10:55:41 qemux86 xserver-nodm[95]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown. Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-01: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-02: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-03: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-04: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-05: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'preferences-desktop' not present in theme Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'computer' not present in theme Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'system-file-manager' not present in theme Apr 08 10:56:46 qemux86 dropbear[184]: Exit before auth: Error reading: Connection reset by peer root@qemux86:~# journalctl -b | grep -i warning Apr 08 10:55:33 qemux86 kernel: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended Apr 08 10:55:33 qemux86 kernel: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended Apr 08 10:55:39 qemux86 kernel[89]: EXT3-fs (hda): warning: feature flags set on rev 0 fs, running e2fsck is recommended Apr 08 10:55:39 qemux86 kernel[89]: EXT3-fs (hda): warning: updating to rev 1 because of new feature flag, running e2fsck is recommended Apr 08 10:55:41 qemux86 xserver-nodm[95]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown. Apr 08 10:55:42 qemux86 xserver-nodm[95]: ** (matchbox-panel:180): WARNING **: No APM support Apr 08 10:55:42 qemux86 xserver-nodm[95]: ** (matchbox-panel:180): WARNING **: Applet "(null)" does not export the "mb_panel_applet_create" symbol. Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-01: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-02: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-03: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-04: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:44 qemux86 xserver-nodm[95]: ** (connman-applet:174): WARNING **: Missing icon connman-signal-05: Fatal error reading PNG image file: Decompression error in IDAT Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'preferences-desktop' not present in theme Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'computer' not present in theme Apr 08 10:55:45 qemux86 xserver-nodm[95]: ** (matchbox-desktop:179): WARNING **: Error loading icon: Icon 'system-file-manager' not present in theme root@qemux86:~# As I can see, there are some PNG image errors which are not so urgent, but there are others like ERROR: failed to open pid file: /var/run/distcc.pid: Permission denied For the rpm-postinst error, the root cause is in rpm-postinsts.bb. It inherits update-rc.d, but it shouldn't. (There's no rpm-postinsts under /etc/init.d directory, and the S98xxx will be deleted after first boot. So inheriting update-rc.d is not ont unnecessary but also wrong.) I'll send out a patch to fix this rpm-postinst error. //Chen Qi FYI, I already have a patch for this queued (along with some other fixes related to read-only-rootfs support). There is now a patch for the rpm-postinsts issue: http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/038201.html Appeared to be fixed in today's build. will verify today verified with poky dylan dab237bc6a7679dfeaa981c14736aedc7b04ecb9 |