Bug 5825

Summary: packages.yoctoproject.org upgrade history produces errors
Product: [Infrastructure] Website Reporter: Ross Burton <ross.burton>
Component: web-contentAssignee: Michael Halstead <mhalstead>
Status: RESOLVED FIXED QA Contact:
Severity: normal    
Priority: Low CC: jefro, melissa, mhalstead, sgw
Version: Production   
Target Milestone: Future   
Hardware: All   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: No (bug/feature does not impact docs)

Description Ross Burton 2014-02-14 16:24:00 UTC
For example:

http://packages.yoctoproject.org/draw_upgrade_history?recipename=libvorbis

Produces this:

<type 'exceptions.IOError'> at /draw_upgrade_history
[Errno 30] Read-only file system: u'/srv/www/vhosts/packages.yoctoproject.org/newserver/webserver/images/libvorbis.png'

It appears to be trying to generate graphs on a read-only file system.
Comment 1 Michael Halstead 2014-02-14 22:45:40 UTC
packages.yoctoproject.org has had read-only access since mid-2012. We have a different server which isn't Internet accessable (PRS1) which writes new data to the filesystem. I've temporarly allowed packages.yoctoproject.org to write to the images directory so those can be regenerated but I'll need to work with the PRS folks on the setup after I get back from vacation next week.
Comment 2 Jeff Osier-Mixon 2014-08-22 19:57:23 UTC
No web content bugs should have a quarterly milestone.
Comment 3 Michael Halstead 2014-10-03 01:47:56 UTC
This has been fixed for a long time.