| Summary: | package_rpm breaks when building inside a docker container | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] BitBake | Reporter: | LetoThe2nd <holzmayr> | ||||
| Component: | bitbake | Assignee: | LetoThe2nd <holzmayr> | ||||
| Status: | RESOLVED WORKSFORME | QA Contact: | |||||
| Severity: | minor | ||||||
| Priority: | Low | CC: | jessica.zhang, jinzhou.zjz, joshuagloe, poky.bs.watcher, poky.watcher | ||||
| Version: | unspecified | ||||||
| Target Milestone: | Future | ||||||
| Hardware: | x86 | ||||||
| OS: | Multiple | ||||||
| Whiteboard: | |||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||
| Verified: | Documentation change: | Don't know | |||||
| Attachments: |
|
||||||
This is interesting but since you have the setup, it'll be great if you can provide a patch We have multiple team members successfully building in Docker containers with package_rpm |
Created attachment 1927 [details] Log of do_roots breaking inside docker with package_rpm When doing a standard minimal build (core-image-minimal for qemuarm or aemux86) inside a docker container (ubuntu 12.04, only the yocto needed packages installed), do_root fails(log attached). package_deb and package_ipk are fine. The error messages suggest ists a host pollution problem, where docker kicks in an breaks the attempts to write.