| Summary: | Toolchain cannot be installed in non-default location | ||
|---|---|---|---|
| Product: | [Yocto Project Subprojects] ADT | Reporter: | Tudor Florea <tudor.florea> |
| Component: | adt | Assignee: | Unassigned <unassigned> |
| Status: | VERIFIED NOTABUG | QA Contact: | Alexandru Georgescu <alexandru.c.georgescu> |
| Severity: | major | ||
| Priority: | Medium+ | CC: | alexandru.c.georgescu, poky.adt.watcher, poky.watcher, richard.purdie |
| Version: | 1.6 | ||
| Target Milestone: | 1.6.1 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | Moved from Laurentiu to Unassigned | ||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | Don't know | |
|
Description
Tudor Florea
2014-05-16 05:38:38 UTC
What do you mean by "cannot be properly used"? Did you source the environment setup script and the compilation failed? gcc -v will always show how the configure script was called. Unfortunately, the relocation script cannot change those paths... For binaries, other than the dynamic loader itself, only the path to the dynamic loader is changed. Can you provide more info regarding what exactly fails? I'm waiting for more info on this. Its expected that people use the toolchain through the environment script which passed the --sysroot= flag to the compiler and toolchain. It is not expected that the relocation script changes the default spec entries. This is therefore not a bug as far as I can tell. Sorry for late feedback on this. It is indeed not a bug. The intent was to deploy the toolchain on a nfs location (in order to be used on many build machine). The issue I encountered turned out to be caused by the nfs and not the toolchain (deployment) itself. e.g: [user@machine ~]$ readlink -f . /nfs/hosts/nfsserver/homes/user [tufl@machine ~]$ pwd /homes/user Verified as per Tudor's comment. |