| Summary: | linux-yocto do_patch fails with a long working directory path | ||
|---|---|---|---|
| Product: | [Yocto Project Subprojects] Kernel | Reporter: | Sami RHATAY <sami.rhatay> |
| Component: | kernel-tooling | Assignee: | Bruce Ashfield <bruce.ashfield> |
| Status: | RESOLVED WORKSFORME | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium | CC: | bruce.ashfield, nat.bailey, randy.macleod, richard.purdie, yp.kernel.watcher, yp.watcher |
| Version: | unspecified | ||
| Target Milestone: | 4.99 | ||
| Hardware: | x86 | ||
| OS: | x86_64 | ||
| Whiteboard: | |||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | Don't know | |
|
Description
Sami RHATAY
2014-11-20 18:23:47 UTC
Forgot to accept this earlier. I'll have a look .. but it is likely just more nasty PATH_MAX issues, which I can deal with. I'm holding onto this one. This is not popping up often (at all), so I'm moving this to 2.99 to clear cycles for more pressing issues. We think this might have been fixed. Tony will try to reproduce it on master. This bug and the linked fix may apply to this bug : 12374 – do_rootfs failed when len(TMPDIR) == 410 https://bugzilla.yoctoproject.org/show_bug.cgi?id=12374 Nat is doing some test builds of: $ bitbake -c patch linux-yocto on master. to see if this fails before the sqlite3 check, that Yoann mentioned, kicks in. So far a depth of 328 is fine and 504 is the limit for sqlite3. Tried to reproduce on Mickledore and wasn't able to. Here are my steps:
1. Did a normal build with a normal path length to ensure everything was working
2. Created a super long working path and moved the poky directory into that path
3. Ran bitbake -c patch linux-yocto in that new subdirectory with a path length of 350 characters (see below)
$ pwd
/server-wxyz/nbailey/long-dirname-testing/aaaaaaaaaa/bbbbbbbbbb/cccccccccc/dddddddddd/eeeeeeeeee/ffffffffff/gggggggg
gg/hhhhhhhhhh/iiiiiiiiii/jjjjjjjjjj/kkkkkkkkkk/llllllllll/mmmmmmmmmm/nnnnnnnnnn/oo
oooooooo/pppppppppp/qqqqqqqqqq/rrrrrrrrrr/ssssssssss/tttttttttt/uuuuuuuuuu/vvvvvvv
vvv/wwwwwwwwww/xxxxxxxxxx/yyyyyyyyyy/zzzzzzzzzz/aaaaaaaaaa/poky/build
$ pwd | wc
1 1 350
... and got a successful build.
4. Repeated steps 2 and 3 for some different path lengths (427 characters, 482 characters, and 471 characters)
I only encountered a failure when the path length was 482, which triggered the sqlite check for database path length > 504 characters, which is something that is already known about as a separate issue. Going to mark this as resolved.
|