Bug 759

Summary: [powerpc] userspace NFS failed with powerpc machines
Product: [Runtime] System Startup Reporter: Qing He <qing.he>
Component: system-startupAssignee: Saul Wold <sgw>
Status: RESOLVED DUPLICATE QA Contact:
Severity: normal    
Priority: Undecided CC: kevin.tian, sgw
Version: unspecified   
Target Milestone: ---   
Hardware: x86   
OS: ppc   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: ---

Description Qing He 2011-02-22 23:04:07 UTC
using sato images from 
http://autobuilder.pokylinux.org/nightly/20110212-1/qemu/qemuppc/

when running poky-qemu and using nfsroot, it hangs in the middle of the boot process:

# poky-qemu qemuppc /path/to/rootfs
...
md: autorun ...
md: ... autorun DONE.
VFS: Mounted root (nfs filesystem) on device 0:12
Freeing unused kernel memory: 256k init
nfs: server 192.168.7.1 not responding, still trying
nfs: server 192.168.7.1 not responding, still trying
nfs: server 192.168.7.1 not responding, still trying
nfs: server 192.168.7.1 not responding, still trying



This issue doesn't happen on qemux86
Comment 1 Qing He 2011-02-22 23:06:01 UTC
Because usual nfs-utils doesn't have the option to mount custom nfsprog and mountprog, I can not verify whether the unfs works well.

However, with kernel nfs as the server, the boot still fails, while the kernel server is fully functional
Comment 2 Qing He 2011-02-23 03:18:20 UTC
marked as duplicate with Bug 414

*** This bug has been marked as a duplicate of bug 414 ***