Bug 7767

Summary: systemd shudown hang
Product: [Runtime] General Runtime Reporter: forrest Kenney <gonesailing>
Component: General RuntimeAssignee: forrest Kenney <gonesailing>
Status: VERIFIED WORKSFORME QA Contact: Cristina Agurida <cristina-danielax.agurida>
Severity: normal    
Priority: Medium CC: cristina-danielax.agurida, randy.e.witt
Version: unspecified   
Target Milestone: 1.9   
Hardware: x86   
OS: Multiple   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: No (bug/feature does not impact docs)

Description forrest Kenney 2015-05-14 18:08:18 UTC
using systemctl shutdown the system hangs.

After a bunch of tracing we have found that systemd is restarting the two services with watchdog timers after they have been initially stopped as part of shutting down.  Eventually, systemd reports a dependency failure for one of these daemons and quits.  At this point the systemd has shutdown enough of the system that we are unable to get in and force a reboot.

Raising the watchdog timeout on the daemons to a large enough value is a allows the system to shutdown.  But that value is way larger than we can tolerate one of these daemons being hung.  

The assumption is we have done something wrong in the our daemons but are not sure what.  Is this a know problem have we done something wrong if so what are we not doing that we should be doing.
Comment 1 Randy Witt 2015-05-14 20:43:51 UTC
I tried running "systemctl poweroff" in qemu using core-image-sato on fido and it shut down successfully.

That suggests it really is something to do with the configuration of your services or with systemd itself. Do you have an example of failure using a Yocto Project image without your services that fails to shutdown using "systemctl poweroff?"

If you do, could you please provide more information on how to reproduce the issue?

If not, I would suggest that you contact the systemd mailing list or IRC.
http://lists.freedesktop.org/mailman/listinfo/systemd-devel
#systemd on irc.freenode.org
Comment 2 forrest Kenney 2015-05-20 14:58:25 UTC
We seem to have stumbled across a work around for the issue that does not involve getting rid of the watchdog timers or changing the timing.



Forrest
Comment 3 forrest Kenney 2015-05-20 15:02:23 UTC
We seem to have stumbled across a work around for the issue that does not involve getting rid of the watchdog timers or changing the timing.



Forrest
Comment 4 Cristina Agurida 2015-05-28 11:21:05 UTC
Verified on master: 5170177719a93a69cc6c7c1218b3f26eed82d6e0 

 I followed the steps of reproducing the issue provided by Randy in his comment and running "systemctl poweroff" worked successfully. I used a core-image-sato image on qemux86.
 Based on Forrest last comment I changed the status in "verified worksforme" since from his initial comment I can't get more details.

Cristina