Bug 8538

Summary: Error failure occur when enabling servlet2.4/2.3 and jsp2.0 from meta-java layer into Yocto build image by using "IMAGE_INSTALL_append"
Product: [Build System, Metadata & Runtime] Other YP Layers Reporter: Arasagesari <arasagesari.al.mahendran>
Component: layersAssignee: Saul Wold <sgw>
Status: RESOLVED FIXED QA Contact:
Severity: major    
Priority: Undecided CC: maxin.john, poky.bs.watcher, poky.watcher
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: x86_64   
Whiteboard:
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: Don't know
Attachments:
Description Flags
ERROR: servlet2.4 not found in the base feeds none

Description Arasagesari 2015-10-19 13:26:44 UTC
Created attachment 2804 [details]
ERROR: servlet2.4 not found in the base feeds

Enabling the servlet-api (servlet2.4/2.3 and jsp2.0) in conf/local.conf as part Yocto custom image with parameter IMAGE_INSTALL_append = " apache2 openjdk-7-jre servlet2.4 jsp2.0” return build failure.

Below are my local.conf Configuration:
--------------------------------------

  PREFERRED_PROVIDER_virtual/java-initial-native = "cacao-initial-native"
  PREFERRED_PROVIDER_virtual/java-native = "jamvm-native"
  PREFERRED_PROVIDER_virtual/javac-native = "ecj-bootstrap-native"
  #For openjdk7:
  PREFERRED_VERSION_openjdk-7-jre = "85b01-2.6.1"
  PREFERRED_VERSION_icedtea7-native = "2.1.3"
  PREFERRED_VERSION_servlet2.4 = "5.5.26"
  PREFERRED_PROVIDER_openjdk-7-jre = "openjdk-7-jre"
  IMAGE_INSTALL_append = " apache2 openjdk-7-jre servlet2.4 jsp2.0”

Error Message:
--------------

NOTE: Installing the following packages: packagegroup-core-ssh-dropbear packagegroup-core-x11-sato-games va-intel packagegroup-core-x11-base smartpm servlet2.4 psplash apache2 gstreamer-vaapi-1.0 packagegroup-core-boot openjdk-7-jre packagegroup-base-extended rpm packagegroup-core-x11-sato locale-base-en-us locale-base-en-gb
ERROR: servlet2.4 not found in the base feeds (haswell_wc corei7-64-intel-common corei7-64 core2-64 x86_64 noarch any all).
Comment 1 Maxin B. John 2015-10-19 14:57:40 UTC
Please use:

IMAGE_INSTALL_append =" apache2 openjdk-7-jre libservlet2.4-java libjsp2.0-java"

meta-java related bugs/patches are discussed in Openembedded-devel mailing list  <openembedded-devel@lists.openembedded.org>