| Summary: | do_rootfs/RPM fails for poky-image-minimal on qemuarm | ||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] Meta-yocto | Reporter: | Denys Dmytriyenko <denis> | ||||||||
| Component: | meta-yocto | Assignee: | Mark Hatle <mark.hatle> | ||||||||
| Status: | RESOLVED FIXED | QA Contact: | |||||||||
| Severity: | normal | ||||||||||
| Priority: | Undecided | CC: | mark.hatle, poky.bs.watcher, poky.watcher | ||||||||
| Version: | unspecified | ||||||||||
| Target Milestone: | --- | ||||||||||
| Hardware: | x86 | ||||||||||
| OS: | Multiple | ||||||||||
| Whiteboard: | |||||||||||
| OS type for building Yocto: | --- | Type of Regression: | --- | ||||||||
| Verified: | Documentation change: | --- | |||||||||
| Attachments: |
|
||||||||||
Created attachment 114 [details]
log.do_rootfs with -vv added to RPM
Added -vv to rpm command
This looks almost exactly like the problem reported by Khem Raj on Ubuntu 11.04-alpha. I was able to reproduce this problem on Ubuntu 10.04.2 running the _OE_ version of bitbake. Using the Poky version of Bitbake, I was unable to reproduce the problem. Investigating further.... Created attachment 120 [details]
Bitbake patch to set the pseudo environment
This patch, applied to current bitbake (oe) head should resolve the problem.
Attached is a fix for this issue. It was determined that a patch from Poky did not make it into the upstream bitbake. This prevented pseudo from running during the rootfs creation, causing RPM to shutdown without an error message. NOTE: this defect is specific to oe-core + oe (upstream) bitbake. It does not affect Yocto 1.0. Fix has been applied to upstream bitbake: http://git.openembedded.org/cgit.cgi/bitbake/commit/?id=e736fa456dee04cb0d177272c1e1c611b1e119d7 A second commit was necessary to activate the first http://git.openembedded.org/cgit.cgi/bitbake/commit/?id=9e9c75761e51c852e029ccd638d9df35d04129da |
Created attachment 113 [details] log.do_rootfs Latest oe-core, building poky-image-minimal for qemuarm on Ubuntu 10.04.2, enabled rpm and opkg. Attached /OE/core-build/tmp/work/qemuarm-poky-linux-gnueabi/poky-image-minimal-1.0-r0/temp/log.do_rootfs.4436