| Summary: | ROOTLESS_X fails to start X, unable to load libraries | ||
|---|---|---|---|
| Product: | [Build System, Metadata & Runtime] OE-Core | Reporter: | Darren Hart <dvhart> |
| Component: | graphics | Assignee: | Edwin Zhai <edwin.zhai> |
| Status: | RESOLVED FIXED | QA Contact: | |
| Severity: | normal | ||
| Priority: | Medium | CC: | edwin.zhai, josh, meta.mr.watcher, meta.watcher, richard.purdie, shane.wang |
| Version: | 1.2 | ||
| Target Milestone: | 1.2 M2 | ||
| Hardware: | x86 | ||
| OS: | Multiple | ||
| Whiteboard: | Resolved after bug 1889 fixed. | ||
| OS type for building Yocto: | --- | Type of Regression: | --- |
| Verified: | Documentation change: | --- | |
| Bug Depends on: | 1889 | ||
| Bug Blocks: | |||
|
Description
Darren Hart
2011-12-09 13:45:07 UTC
Does http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=ccc84d94b8ff59365806b57fe90a7bacdeb16b5d fix this? No, but the error changes: Fatal server error: xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) (In reply to comment #2) > No, but the error changes: > > Fatal server error: > xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) This is he same error mesg if I enabled rootless X in qemu. The issue is that rootless requires KMS in kernel config, which depends on physical DRI. Qemu doesn't support DRI, so it failed. What about n450? (In reply to comment #2) > No, but the error changes: > > Fatal server error: > xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) I have checked latest master (021848b), things are a little bit different: rootless X start fail because xuser has no home directory. After create a new user with right permission as xuser, I can start rootless X as the new user. Also checked the kernel config of atom-pc, KMS is enabled by default. So the issue here is that useradd.bbclass fail to add the home directory even with the fix http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=ccc84d94b8ff59365806b57fe90a7bacdeb16b5d I'll open a new bug for it, and make this bug depends on it. (In reply to comment #4) > (In reply to comment #2) > > No, but the error changes: > > > > Fatal server error: > > xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) > > I have checked latest master (021848b), things are a little bit different: > rootless X start fail because xuser has no home directory. After create a new > user with right permission as xuser, I can start rootless X as the new user. Do we know why rootless X requires a home directory? Presumably this is just so that the X server has somewhere to write files? Can we use /tmp instead? (In reply to comment #5) > (In reply to comment #4) > > > > I have checked latest master (021848b), things are a little bit different: > > rootless X start fail because xuser has no home directory. After create a new > > user with right permission as xuser, I can start rootless X as the new user. > > Do we know why rootless X requires a home directory? Presumably this is just so > that the X server has somewhere to write files? Can we use /tmp instead? It's not the perfect solution. Even can start rootless X, we still have various failure without HOME directory. e.g open matchbox-terminal. Fix it on useradd is the right way, I think, After bug 1889 got fixed, I have tested latest atom image @ http://autobuilder.pokylinux.org/nightly/20120328-1/machines/atom-pc/core-image-sato-atom-pc.hddimg rootless X start successfully. |