Bug 1818 - ROOTLESS_X fails to start X, unable to load libraries
Summary: ROOTLESS_X fails to start X, unable to load libraries
Status: RESOLVED FIXED
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: graphics (show other bugs)
Version: 1.2
Hardware: x86 Multiple
: Medium normal
Target Milestone: 1.2 M2
Assignee: Edwin Zhai
QA Contact:
URL:
Whiteboard: Resolved after bug 1889 fixed.
Depends on: 1889
Blocks:
  Show dependency tree
 
Reported: 2011-12-09 13:45 UTC by Darren Hart
Modified: 2012-03-30 05:19 UTC (History)
6 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darren Hart 2011-12-09 13:45:07 UTC
First seen in the n450 (Bug 1797), using ROOTLESS_X causes X to fail to load with errors loading dri libraries that do exist on the filesystem. ROOTLESS_X has been disabled in n450 for now. Atom-pc still sees this failure.
Comment 2 Darren Hart 2011-12-16 09:57:21 UTC
No, but the error changes:

Fatal server error:
xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
Comment 3 Edwin Zhai 2011-12-21 17:41:45 UTC
(In reply to comment #2)
> No, but the error changes:
> 
> Fatal server error:
> xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

This is he same error mesg if I enabled rootless X in qemu. The issue is that rootless requires KMS in kernel config, which depends on physical DRI. Qemu doesn't support DRI, so it failed. What about n450?
Comment 4 Edwin Zhai 2012-01-10 17:48:10 UTC
(In reply to comment #2)
> No, but the error changes:
> 
> Fatal server error:
> xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

I have checked latest master (021848b), things are a little bit different:
rootless X start fail because xuser has no home directory. After create a new user with right permission as xuser, I can start rootless X as the new user.

Also checked the kernel config of atom-pc, KMS is enabled by default. 

So the issue here is that useradd.bbclass fail to add the home directory even with the fix http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=ccc84d94b8ff59365806b57fe90a7bacdeb16b5d

I'll open a new bug for it, and make this bug depends on it.
Comment 5 Joshua Lock - Disabled 2012-02-21 11:51:05 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > No, but the error changes:
> > 
> > Fatal server error:
> > xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
> 
> I have checked latest master (021848b), things are a little bit different:
> rootless X start fail because xuser has no home directory. After create a new
> user with right permission as xuser, I can start rootless X as the new user.

Do we know why rootless X requires a home directory? Presumably this is just so that the X server has somewhere to write files? Can we use /tmp instead?
Comment 6 Edwin Zhai 2012-02-21 17:14:34 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > 
> > I have checked latest master (021848b), things are a little bit different:
> > rootless X start fail because xuser has no home directory. After create a new
> > user with right permission as xuser, I can start rootless X as the new user.
> 
> Do we know why rootless X requires a home directory? Presumably this is just so
> that the X server has somewhere to write files? Can we use /tmp instead?

It's not the perfect solution. Even can start rootless X, we still have various failure without HOME directory. e.g open matchbox-terminal.

Fix it on useradd is the right way, I think,
Comment 7 Edwin Zhai 2012-03-30 05:19:05 UTC
After bug 1889 got fixed, I have tested latest atom image @
http://autobuilder.pokylinux.org/nightly/20120328-1/machines/atom-pc/core-image-sato-atom-pc.hddimg

rootless X start successfully.