Bug 10257 - VNC session handling seems broken on the new AB
Summary: VNC session handling seems broken on the new AB
Status: RESOLVED FIXED
Alias: None
Product: AutoBuilder
Classification: Infrastructure
Component: autobuilder (show other bugs)
Version: 2.2
Hardware: x86 Multiple
: Undecided normal
Target Milestone: ---
Assignee: Joshua Lock
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2016-09-12 08:09 UTC by Richard Purdie
Modified: 2016-09-14 09:53 UTC (History)
3 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Purdie 2016-09-12 08:09:35 UTC
http://autobuilder.yocto.io:8010/builders/nightly-mips/builds/36/steps/Running%20Sanity%20Tests/logs/stdio

Note the:

Xvnc not running, attempting restart
Killing Xtightvnc process ID 12010

New 'X' desktop is debian8:1

Starting applications specified in /home/pokybuild/.vnc/xstartup
Log file is /home/pokybuild/.vnc/debian8:1.log


at the start and the fact that qemu appears to fail. I suspect that VNC is being killed when its really running and this is causing sanity test failures. The previous krogoth build hit this particularly badly, presumably as restarts are happening mid build.
Comment 1 Joshua Lock 2016-09-12 13:35:18 UTC
The patch to resolve #8210 switched from using netstat to detect a running vncserver to using `pidof Xvnc`, however on debian-based OS in the cluster the vncserver wrapper script starts Xtightvnc (not Xvnc) resulting in a failed check for a running VNC server and multiple servers started.
Comment 2 Joshua Lock 2016-09-12 14:23:37 UTC
Patch out for review:

https://lists.yoctoproject.org/pipermail/yocto/2016-September/031943.html
Comment 3 Joshua Lock 2016-09-14 09:53:27 UTC
Patch merged and deployed to both AB clusters