Setting DEPLOY_DIR = "${TOPDIR}/deploy" will make sstate-cache mostly unusable between builds in different directories since neither DEPLOY_DIR or TOPDIR are in BB_HASHBASE_WHITELIST. Unless there is a reason not to, I suggest adding DEPLOY_DIR and TOPDIR to BB_HASHBASE_WHITELIST.
I gave this some thought and I think there is a good reason not to add TOPDIR. The problem is that if TOPDIR moves and these variables are in BB_HASHBASE_WHITELIST, they're also in BB_HASHCONFIG_WHITELIST and therefore the system wouldn't even reparse. That would lead to really nasty errors and is clearly something we want to avoid. Adding DEPLOY_DIR on the other hand should be safe enough so I'll propose a patch for that.
http://git.yoctoproject.org/cgit.cgi/poky/commit/?id=8babb56c92fa1064e86e944b3947e6e1babe10b2