The errors link to errors.yp.o on the new cluster doesn't work. The reason is that errors.yp.o only recognises the old cluster as "the Autobuilder" and therefore the autobuilder filter for the new cluster doesn't return any results. The same query without the autobuilder filter does return results. Unfortunately the errors.yp.o link in the yocto-autobuilder templates is hard-coded, it would likely make yocto-autobuilder more useful for non-upstream use if the errors instance were configurable. Then we could add a configuration for the yocto.io cluster which works.
We can resolve this by changing the submitter id's on both clusters to match the filter pattern. Currently yocto.io cluster submitter id's are of the form: yoctoio-autobuilder-$HOSTDISTRO and yoctoproject.org cluster submitter id's are of the form: production-yocto-autobuilder-$HOSTDISTRO the error-report-web code filters submitter names that include "yocto-autobuilder".
Links are working now so marking this resolved.
Pulled https://lists.yoctoproject.org/pipermail/yocto/2018-November/043203.html in on production to complete the fix.