Bug 11722 - Error links broken on errors.yoctoproject.org for new cluster
Summary: Error links broken on errors.yoctoproject.org for new cluster
Status: RESOLVED FIXED
Alias: None
Product: Error Reporting tool
Classification: Yocto Project Subprojects
Component: Error Reporting Tool (show other bugs)
Version: unspecified
Hardware: x86 Multiple
: Medium normal
Target Milestone: 4.99
Assignee: Michael Halstead
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2017-06-26 17:47 UTC by Stephano Cetola
Modified: 2018-11-08 13:57 UTC (History)
6 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephano Cetola 2017-06-26 17:47:48 UTC
The errors link to errors.yp.o on the new cluster doesn't work. The
reason is that errors.yp.o only recognises the old cluster as "the
Autobuilder" and therefore the autobuilder filter for the new cluster
doesn't return any results. The same query without the autobuilder
filter does return results.

  Unfortunately the errors.yp.o link in the yocto-autobuilder templates
is hard-coded, it would likely make yocto-autobuilder more useful for
non-upstream use if the errors instance were configurable. Then we
could add a configuration for the yocto.io cluster which works.
Comment 1 Joshua Lock 2017-09-21 14:43:33 UTC
We can resolve this by changing the submitter id's on both clusters to match the filter pattern. 

Currently yocto.io cluster submitter id's are of the form:
  yoctoio-autobuilder-$HOSTDISTRO 

and yoctoproject.org cluster submitter id's are of the form:
  production-yocto-autobuilder-$HOSTDISTRO

the error-report-web code filters submitter names that include "yocto-autobuilder".
Comment 2 Michael Halstead 2018-11-08 13:55:10 UTC
Links are working now so marking this resolved.
Comment 3 Michael Halstead 2018-11-08 13:57:38 UTC
Pulled https://lists.yoctoproject.org/pipermail/yocto/2018-November/043203.html in on production to complete the fix.