Created attachment 183 [details] Detailed message There is no such issue in Yocto1.1 20110624 build. Commit Information: Tree/Branch: Poky/Master Poky Commit: ad2363278f0ea86fcf3464f8f6073d3a3d06be63 Meta Branch: Master Meta Commit: 92fc07a5f1b98779806cdcc2341487ff5ea5a238 Image location: http://autobuilder02.pokylinux.org/n450-master/nightly/20110702-1/machines/n450/x86_32/core-image-sato-sdk-live-n450-20110702083055.hddimg.bz2 Boot live image from USB device, X server message issue but Psplash is OK. And you can check the Xlog.0.log file from attachment for more information.
This is most likely the same problem as 1207, just different hardware. *** This bug has been marked as a duplicate of bug 1207 ***
Commit Information: Tree/Branch: Poky/1.1_M2 Poky Commit: 8df2a558b4d61778a669705b867969abe3514846 Meta Branch: 1.1_M2 Meta Commit: 92fc07a5f1b98779806cdcc2341487ff5ea5a238 Image location: http://autobuilder02.yoctoproject.org/n450-1.1_M2/nightly/20110708-1/machines/n450/x86_32/core-image-sato-sdk-live-n450-20110709045049.hddimg.bz2 When boot up the Yocto from real machine, psplash failed to work. But run the command '/etc/init.d/xserver-nodm start' in text model, X can start up.
If we start system with psplash=false and start X server by manual with cmdline, "/etc/init.d/xserver-nodm start", X server could start successfuly.
This is marked RESOLVED DUPLICATE of bug 1207, but the further activity makes me think that's not the case. I don't have working blacksand hardware but Darren does, and furthermore, he's the one listed as the maintainer in MAINTAINERS for the n450, so re-assigning it to Darren.
Reopening
Trying to reproduce, my blacksand at home no longer accepts keyboard input and I can't boot without it. I'll try again with the board in the office. :(
As I won't be able to look at this until tomorrow at the earliest, I would appreciate it if Wenhua or Jiajun could narrow down when the failure occured - either using the autobuilder nightly builds or via a git bisect. This can be a time consuming process if we need to build the release (although using sato instead of sato-sdk should speed that up), if we are to fix this by M2 (Friday) I will need the help to narrow down when this bug was introduced.
On my second Black Sand system, the image: http://autobuilder02.pokylinux.org/n450-master/nightly/20110702-1/machines/n450/x86_32/core-image-sato-sdk-live-n450-20110702083055.hddimg.bz2 boots to the yocto splash screen, the gray bar gets to about 99% and the sato desktop does not come up. Switching to the console (ctrl+alt+f1) listed various errors: Fatal server error: [3930084.900] xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory) ... xinit: giving up xinit: unable to connect to X server: Connection refused xinit: xserver error ... * Starting Avahi mDNS/DNS=SD Daemon: avahi-daemon ...done. sh: missing ] Starting Telephony daemon o matchbox desktop timed out with fbset missing errors o sh complaint about a missing ] from an unknown source. starting X manually at this point brings up the sato desktop successfully: It complains about module fbcon not being found: FATAL: Module fbcon not found. And also about fbset not being found: /etc/X11/Xsession: /etc/formfactor/config: line 33: fbset: not found (for multiple lines) /etc/init.d/xserver-nodm start I tried starting the Xserver later in the process, that did not help: root@n450:/etc/rc5.d# mv S09xserver-nodm S90xserver-nodm Interestingly, from the serial console I tried: # echo "test" > /dev/tty0 Then switched to that console with ctrl+alt+f1 and the string did not appear. Running the echo command again does cause "test" to appear on the vga console, as do subsequent invocations. It's almost as though the tty0 device doesn't exist until we switch to it - although I should have seen an error with the first echo command.
Changing /etc/X11/Xusername to "root" allows the Xserver to start on boot.
I checked the logs and nothing has changed in linux-yocto (meta|atom-pc), meta-intel/meta-n450, or meta/recipes-graphics since the 20110624 build.
There appears to be some kind of strange race setting up the /dev/* permissions, or perhaps in whatever services are necessary for the sudo command to get the proper group permissions for the xuser user. If I update xserver-nodm with the following in the xuser permissions block the XServer starts successfully: sleep 60 chmod a+rw /dev/tty[0-3] chmod a+rw /dev/dri/card0 Keep in mind that on normal boot, X fails to start, but if I just login on the serial console as root and run "/etc/inid.d/xserver-nodm start" it starts up properly. So the added permissions aren't needed after login. Some race with udev maybe? Does logging in trigger any kind of /dev/* updates?
As it turns out this started with the upgrade of the sudo package with the following commit: 7c6f47b sudo: upgrade to v1.8.1p2
Patch reverting the sudo upgrade has been sent to oe-core.
I bisect sudo release, found this bug occur from 1.8.0. The biggest new feature in 1.8 branch is that a new frame work is used to allow 3rd party plugins in sudo. I suspect this change cause some disorder in execution, so that some checks fail in early stage due to unavailable resource. Debug is on going. One work around is we can upgrade it to latest 1.7 branch rather than 1.8.
I believe latest sudo wait for some resource that is unavailable in early phase of booting. This is probably caused by new framework for 3rd party plugins, which is not easy to fix in a short time. But after changing sudo to su, I can start X window successfully. We can use it in our script and fix sudo bugs in future. Patch will be out soon. Thanks, Edwin
This issue not reappear in current build. Tree/Branch: Poky/1.1_M3 Poky Commit id: abdec68876ac7ce1a6d5c223d1757b7e8a14b85f Meta Branch 1.1_M3 Meta Commit id: da93dc24fd73079b4dbb6811b83e44a2036d54ef
Image location: http://autobuilder02.yoctoproject.org/n450-1.1_M3/nightly/20110807-1/machines/n450/x86_32/core-image-sato-sdk-n450-20110807104050.hddimg.bz2
Got fix @ master. http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=cb3de7d9ca133b5980dd2aecdd10fc6d78670a24