Bug 12562 - samba without LDAP fails in configure
Summary: samba without LDAP fails in configure
Status: RESOLVED MOVED
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: core (show other bugs)
Version: 2.3.4
Hardware: x86 Multiple
: Undecided normal
Target Milestone: ---
Assignee: Ross Burton
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2018-02-21 12:27 UTC by Jens Bäckman
Modified: 2018-02-21 12:30 UTC (History)
2 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Bäckman 2018-02-21 12:27:22 UTC
My conf/local.conf contains the following row:

  PACKAGECONFIG_remove_pn-samba = "ldap"

When running 'bitbake samba', this error occurs in do_configure:

| Active Directory support not available: LDAP support is not available.
| /home/chainsaw/src/yocto-pyro/build/tmp/work/cortexa7hf-neon-vfpv4-poky-linux-gnueabi/samba/4.6.2-r0/samba-4.6.2/source3/wscript:813: error: Active Directory support not found. Use --without-ads for building without Active Directory support. ADS support improves communication with Active Directory domain controllers.
| WARNING: exit code 1 from a shell command.

This is probably a simple fix: adding a PACKAGECONFIG[ads] option and modifying the SAMBA4_PDB_MODULES variable to only add pdb_ads if configured to use it.
Comment 1 Ross Burton 2018-02-21 12:30:49 UTC
Samba isn't part of oe-core, but a recipe in meta-networking.  Bugs for meta-networking should be reported on the openembedded-devel mailing list.