Bug 12888 - [Test Case 1550] test_dependency_explorer_is_launched
Summary: [Test Case 1550] test_dependency_explorer_is_launched
Status: RESOLVED DUPLICATE of bug 12670
Alias: None
Product: BitBake
Classification: Build System, Metadata & Runtime
Component: bitbake (show other bugs)
Version: 2.5.1
Hardware: x86 Multiple
: Undecided normal
Target Milestone: ---
Assignee: Richard Purdie
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2018-08-14 11:21 UTC by pavan
Modified: 2018-08-15 02:02 UTC (History)
3 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments
It is giving log as Failed to connect to Mir: Failed to connect to server socket: No such file or directory Unable to init server: Could not connect: Connection refused (30.33 KB, image/png)
2018-08-14 11:21 UTC, pavan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavan 2018-08-14 11:21:13 UTC
Created attachment 4361 [details]
It is giving log as Failed to connect to Mir: Failed to connect to server socket: No such file or directory Unable to init server: Could not connect: Connection refused

STEPS TO REPRODUCE: 1. clone poky2. cd poky3. source oe-init-build-env4. bitbake core-image-full-cmdline5. bitbake -u taskexp -g core-image-full-cmdline
NOTE: To execute the last command of this test, it's necessary that the machine is executing an X11 server, or if that's not the case (for example, if running the test on a headless server), it is required to enable ssh X11 forwarding on both, the server and the client, and have the X11 server running on the client.
The instructions to enable X11 forwarding vary between distributions. But for example, these are the steps to enable it between a server running openSUSE Leap 42.1 and a client with Fedora 24:A. On the server, make sure /home/<username>/.ssh/config contains the line:    ForwardX11 yesB. On the server, make sure xauth is installed by running:    which xauthC. On the client, connect to the server, enabling X11 forwarding, for example by using:    ssh -X user@server
NOTE 2: depexp was renamed to taskexp on 2.3 M4

EXPECTED OUTCOME: 4. Image should be successfully built5. Verify that a "dependency explorer" is opened and file    dependencies are listed  

After running 5th step it is giving log as follows:
bitbake -u taskexp -g core-image-full-cmdline

Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

"I have attached the screenshot"
Comment 1 pankaj yadav 2018-08-15 02:02:42 UTC
This is a duplicate bug of https://bugzilla.yoctoproject.org/show_bug.cgi?id=12670

*** This bug has been marked as a duplicate of bug 12670 ***