Bug 14440 - 'hashserv.db-shm' file not found error in test_hashserv_multiple_setscene
Summary: 'hashserv.db-shm' file not found error in test_hashserv_multiple_setscene
Status: RESOLVED FIXED
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: oe-core other (show other bugs)
Version: 3.4
Hardware: x86 Multiple
: Medium+ normal
Target Milestone: 4.0 M1
Assignee: Richard Purdie
QA Contact:
URL:
Whiteboard: AB-INT AB-INT-TMPFS
Depends on:
Blocks:
 
Reported: 2021-06-17 13:54 UTC by Alexandre Belloni
Modified: 2021-10-17 12:38 UTC (History)
4 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Belloni 2021-06-17 13:54:02 UTC
https://autobuilder.yoctoproject.org/typhoon/#/builders/80/builds/2152/steps/11/logs/stdio

oe-selftest-debian debian10-ty-3


======================================================================
ERROR: test_hashserv_multiple_setscene (bb.tests.runqueue.RunQueueTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/pokybuild/yocto-worker/oe-selftest-debian/build/bitbake/lib/bb/tests/runqueue.py", line 360, in test_hashserv_multiple_setscene
    self.shutdown(tempdir)
  File "/usr/lib/python3.7/tempfile.py", line 944, in __exit__
    self.cleanup()
  File "/usr/lib/python3.7/tempfile.py", line 948, in cleanup
    _rmtree(self.name)
  File "/usr/lib/python3.7/shutil.py", line 491, in rmtree
    _rmtree_safe_fd(fd, path, onerror)
  File "/usr/lib/python3.7/shutil.py", line 429, in _rmtree_safe_fd
    _rmtree_safe_fd(dirfd, fullname, onerror)
  File "/usr/lib/python3.7/shutil.py", line 449, in _rmtree_safe_fd
    onerror(os.unlink, fullname, sys.exc_info())
  File "/usr/lib/python3.7/shutil.py", line 447, in _rmtree_safe_fd
    os.unlink(entry.name, dir_fd=topfd)
FileNotFoundError: [Errno 2] No such file or directory: 'hashserv.db-shm'
Comment 1 Randy MacLeod 2021-06-17 14:51:31 UTC
Seems like a PR server race condition on shutdown.
Comment 3 Richard Purdie 2021-10-17 12:38:31 UTC
Resolved as above