Bug 14677 - systemd.SystemdServiceTests.test_systemd_disable_enable intermittent failure: no filesystem space on target
Summary: systemd.SystemdServiceTests.test_systemd_disable_enable intermittent failure:...
Status: RESOLVED WORKSFORME
Alias: None
Product: Runtime Testing
Classification: QA/Testing
Component: oeqa/runtime (show other bugs)
Version: 3.4
Hardware: x86 Multiple
: Medium normal
Target Milestone: 4.2
Assignee: Randy MacLeod
QA Contact:
URL:
Whiteboard: AB-INT AB-HAVE-PLAN
Depends on:
Blocks:
 
Reported: 2022-01-08 00:01 UTC by Alexandre Belloni
Modified: 2023-04-11 20:32 UTC (History)
3 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Belloni 2022-01-08 00:01:52 UTC
https://autobuilder.yoctoproject.org/typhoon/#/builders/102/builds/2447/steps/13/logs/stdio

Startup finished in 7.425s (kernel) + 1min 35.797s (userspace) = 1min 43.223s.
Target boot time 103.223 exceeds systemd's TimeoutStartSec 90
Traceback (most recent call last):
  File "/home/pokybuild/yocto-worker/qemumips-alt/build/meta/lib/oeqa/core/decorator/__init__.py", line 36, in wrapped_f
    return func(*args, **kwargs)
  File "/home/pokybuild/yocto-worker/qemumips-alt/build/meta/lib/oeqa/core/decorator/__init__.py", line 36, in wrapped_f
    return func(*args, **kwargs)
  File "/home/pokybuild/yocto-worker/qemumips-alt/build/meta/lib/oeqa/runtime/cases/systemd.py", line 120, in test_systemd_disable_enable
    self.systemctl('disable', 'avahi-daemon.service')
  File "/home/pokybuild/yocto-worker/qemumips-alt/build/meta/lib/oeqa/runtime/cases/systemd.py", line 23, in systemctl
    self.assertEqual(status, expected, message)
AssertionError: 1 != 0 : SYSTEMD_BUS_TIMEOUT=240s systemctl disable avahi-daemon.service
Removed /etc/systemd/system/sockets.target.wants/avahi-daemon.socket.
Removed /etc/systemd/system/multi-user.target.wants/avahi-daemon.service.
Removed /etc/systemd/system/dbus-org.freedesktop.Avahi.service.
Failed to reload daemon: Refusing to reload, not enough space available on /run/systemd. Currently, 14.6M are free, but a safety buffer of 16.0M is enforced.
Comment 1 Randy MacLeod 2022-01-13 15:37:37 UTC
Only happened once, it seems there was not enough space on the target.
Comment 2 Randy MacLeod 2022-04-14 15:08:25 UTC
We should figure out if we are close to the FS space allocation limit.
Comment 3 Luca Ceresoli 2022-07-25 18:58:17 UTC
https://autobuilder.yoctoproject.org/typhoon/#/builders/102/builds/3334/steps/13/logs/stdio

qemumips-alt on opensuse154-ty-2
Comment 4 Luca Ceresoli 2022-07-25 19:01:39 UTC
Forget the above comment. It should have been in another bug, sorry.
Comment 5 Randy MacLeod 2023-02-16 15:44:32 UTC
Why are we so low on space for this configuration.
Comment 6 Randy MacLeod 2023-04-11 20:32:16 UTC
A single occurrence in early 2022. It's not worth changing our image sizes for such a rare error. Re-open if seen again.