Bug 15870 - AB-INT: gpg: can't connect to the gpg-agent: File name too long
Summary: AB-INT: gpg: can't connect to the gpg-agent: File name too long
Status: RESOLVED FIXED
Alias: None
Product: Functional (self) Testing
Classification: QA/Testing
Component: oe-selftest (show other bugs)
Version: unspecified
Hardware: x86 Multiple
: Undecided normal
Target Milestone: ---
Assignee: Unassigned
QA Contact:
URL:
Whiteboard: AB-INT
Depends on:
Blocks:
 
Reported: 2025-05-21 07:12 UTC by Mathieu Dubois-Briand
Modified: 2025-05-22 14:31 UTC (History)
1 user (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Dubois-Briand 2025-05-21 07:12:48 UTC
2025-05-09 14:01:56,672 - oe-selftest - INFO - runtime_test.TestImage.test_testimage_apt (subunit.RemotedTestCase)
2025-05-09 14:01:56,673 - oe-selftest - INFO -  ... FAIL
...
ERROR: core-image-full-cmdline-1.0-r0 do_rootfs: GPG exited with code 2: gpg: can't connect to the gpg-agent: File name too long
gpg: keydb_search failed: No agent running
gpg: skipped "testuser": No agent running
gpg: signing failed: No agent running
Comment 1 Mathieu Dubois-Briand 2025-05-21 07:27:48 UTC
oe-selftest-debian debian12-vk-6 master-next completed at 2025-05-09T14:40:40Z
https://autobuilder.yoctoproject.org/valkyrie/#/builders/35/builds/1528/steps/14/logs/stdio
Comment 2 Richard Purdie 2025-05-22 14:31:45 UTC
This was caused by some of the pseudo changes and has been subsequently resolved by not covering /tmp with pseudo.