Bug 16071 - AB-INT: indexing: Connection timed out to docs.yoctoproject.org port 22 (Fedora 43)
Summary: AB-INT: indexing: Connection timed out to docs.yoctoproject.org port 22 (Fedo...
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure General
Classification: Infrastructure
Component: infrastructure-general (show other bugs)
Version: unspecified
Hardware: x86 Multiple
: Medium+ normal
Target Milestone: 6.0 M1
Assignee: Michael Halstead
QA Contact:
URL:
Whiteboard: AB-INT
Depends on:
Blocks:
 
Reported: 2025-11-20 08:34 UTC by Mathieu Dubois-Briand
Modified: 2025-11-25 19:58 UTC (History)
1 user (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Dubois-Briand 2025-11-20 08:34:38 UTC
I remember seeing a similar error last week, so opening a ticket to track this

+ rsync -irlp --checksum --ignore-times releases.json docs@docs.yoctoproject.org:dashboard/
ssh: connect to host docs.yoctoproject.org port 22: Connection timed out
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(232) [sender=3.4.1]
Comment 1 Mathieu Dubois-Briand 2025-11-20 08:43:54 UTC
indexing fedora43-vk-1 master completed at 2025-11-20 02:22:11+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38550/steps/16/logs/stdio
Comment 2 Mathieu Dubois-Briand 2025-11-20 15:43:01 UTC
Previous fail: https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/37882
Comment 3 Mathieu Dubois-Briand 2025-11-20 15:45:20 UTC
So the two fails happened about exactly one week apart, with less than 1 hour of drift:

complete_at    1762997746 (2025-11-13T02:35:46+01:00) 
complete_at    1763605331 (2025-11-20T03:22:11+01:00) 

So is something happening every weeks on the infrastructure?
Comment 4 Mathieu Dubois-Briand 2025-11-21 15:06:41 UTC
indexing fedora43-vk-1 master completed at 2025-11-20 20:51:11+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38621/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-20 23:05:48+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38633/steps/16/logs/stdio
Comment 5 Mathieu Dubois-Briand 2025-11-25 09:38:03 UTC
I just saw all previous failures and the ones below were from the Fedora 43
worker, so this probably just another issue with Fedora 43.

I tired to run the curl command by hand on the worker and it succeed. So I'm not
sure if it's intermittent or if there is something else.

indexing fedora43-vk-1 master completed at 2025-11-21 15:25:39+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38698/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-21 19:35:09+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38715/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-22 10:07:31+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38773/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-22 16:33:51+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38799/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-22 18:48:48+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38808/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-22 21:18:39+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38818/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-23 18:50:48+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38904/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-23 23:03:52+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38921/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-24 03:50:31+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38940/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-24 13:36:15+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38979/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-24 14:04:55+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38981/steps/16/logs/stdio

indexing fedora43-vk-1 master completed at 2025-11-24 15:20:13+00:00
https://autobuilder.yoctoproject.org/valkyrie/#/builders/104/builds/38986/steps/16/logs/stdio
Comment 6 Michael Halstead 2025-11-25 19:58:16 UTC
The fedora43-vk-1 worker is coming from a new netblock and wasn't allowed past the firewall. I've adjusted the rules, tested from the CLI and this succeeds now.