Bug 2466 - X server can not startup on qemuarm/qemumips/qemuppc/e-Menlow with nightly build (20120515-2)
Summary: X server can not startup on qemuarm/qemumips/qemuppc/e-Menlow with nightly bu...
Status: CLOSED FIXED
Alias: None
Product: Meta-yocto
Classification: Build System, Metadata & Runtime
Component: meta-yocto (show other bugs)
Version: unspecified
Hardware: x86 Multiple
: Medium normal
Target Milestone: 1.3 M1
Assignee: Saul Wold
QA Contact:
URL:
Whiteboard: (Scheduled)
Depends on:
Blocks:
 
Reported: 2012-05-17 08:30 UTC by liang li
Modified: 2012-06-01 05:31 UTC (History)
9 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: ---


Attachments
The file of /var/log/Xorg.o.log on e-Menlow (27.98 KB, application/octet-stream)
2012-05-18 05:58 UTC, Hongna Xu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description liang li 2012-05-17 08:30:43 UTC
images from :
http://autobuilder.yoctoproject.org/pub/nightly/20120515-2/machines/qemu/
when run "runqemu" commands below:
runqemu qemuppc  vmlinux-3.2.11+git5+6b3d4e09aa2531e9649f3f03827b7efbccfcec03_2+cf3e188cf2a18c48a0e6f9ca54c36e6ac39512ec-r1-qemuppc-20120515214512.bin  core-image-sato-qemuppc-20120515214512.rootfs.ext3 ext3 

x can not start,desktop of qemu target can not be found.
when use command "ssh 192.168.7.2" ,can login to the qemu target.

when use "nographic" options of "runqemu" ,the qemu target can boot to login prompt,and following errors be found when use "nographic" option:
qemuppc login: xinit: giving up
xinit: unable to connect to X server: No such file or directory
xinit: server error

test env :
hosts:ubuntu 12.04 x86_64,fedora 16 i686,opensuse 12.1 x86_64.
Comment 1 liang li 2012-05-17 08:40:06 UTC
git info:f3ba3cb6af96aebf5167bb1565edf11cceb7897f
branch :poky/master
Comment 2 Hongna Xu 2012-05-18 05:58:17 UTC
Created attachment 519 [details]
The file of /var/log/Xorg.o.log on e-Menlow

I got the same error when boot emenlow:
*********************
xinit: giving up
xinit: unable to connect X server : No such file or directory
xinit: server error
**********************
Comment 3 Hongna Xu 2012-05-18 06:02:21 UTC
git info: 12b4543ac9f54c0db0ee4a7ee546a71946a051f8
tree/branch: poky/master
image location: http://autobuilder03.jf.intel.com/pub/nightly-meta-intel/20120515-1/machines/emenlow/core-image-sato-sdk-emenlow.hddimg
Comment 4 Saul Wold 2012-05-18 06:27:00 UTC
I beleive that this was a test with MUT and the updated Qemu xserver-xorg patches, I will work with Khem on this.
Comment 5 liang li 2012-05-21 04:10:55 UTC
using master newest, X server can start up on qemuppc sato image:
git info :b4c8c74a45e386f99344cf9799eb5294ad6c9e3e
branch: poky/master
Comment 6 Saul Wold 2012-05-22 22:40:14 UTC
I have tested this against the latest master build on the Autobuilder as of today, I tested qemumips, qemuppc, qemuarm and qemux86.  All booted no problem and started X correctly, I could mouse and use keyboard.

I do not have an emenlow to test, so please check emenlow and confirm, then I will close this.
Comment 7 liang li 2012-05-24 08:53:39 UTC
images from :
http://autobuilder.yoctoproject.org/pub/nightly/20120523-2/machines/qemu/
no such error, qemuarm,qemumips,qemuppc's X server all can startup using "runqemu" command.

git info: 094742bed2fc01d55f572da946fcfa7a48521401
git branch: poky/master
Comment 8 Hongna Xu 2012-05-24 09:17:38 UTC
I try e-Menlow with the lastest master, X didn't work either but with different phenomenon, so i will open a new bug for it.
image location:http://autobuilder03.jf.intel.com/pub/emenlow/20120425-1/machines/emenlow/ 
git info: 094742bed2fc01d55f572da946fcfa7a48521401
git branch: poky/master
Comment 10 Saul Wold 2012-05-31 03:27:01 UTC
eMenlow issue has been fixed also
Comment 11 Hongna Xu 2012-06-01 05:31:39 UTC
Close it, and for emenlow issue, we open a new bug 2507.