zypper refresh command fails to complete after adding a certain repository, as presented below: ***************************************************************************** root@qemux86-64:~/scripts# zypper refresh Retrieving repository 'repo' metadata [|] File 'repomd.xml' from repository 'repo' is unsigned, continue? [yes/no] (no): yes Retrieving repository 'repo' metadata [done] Building repository 'repo' cache [done] Error building the cache: 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo/solv' '/var/cache/zypp/raw/repo' /usr/bin/repo2solv.sh: line 244: 760 Done ( echo '<rpmmd>'; if test -f $primxml; then repomd_decompress $primxml; echo; fi; susedataxml=`repomd_findfile susedata susedata.xml`; if test -f "$susedataxml"; then repomd_decompress "$susedataxml"; fi; echo '</rpmmd>' ) 761 | grep -v '\?xml' 762 | sed '1i\<?xml version="1.0" encoding="UTF-8"?>' 763 Killed | rpmmd2solv $parser_options > $primfile Skipping repository 'repo' because of the above error. Could not refresh the repositories because of errors. ************************************************************************* Tried with multiple repositories, but no luck
Is it also failed for 1.3?
The behavior is also encountered on X86-64 QEMU images with 1.3 build.
Some more info on this: The failing command here is: repo2solv.sh -o /var/cache/zypp/solv/repo/solv /var/cache/zypp/raw/repo The strange thing is, using it manually, it fails on both qemux86 and qemux86-64, even though the 'zypper refresh' command works on qemux86 but fails on qemux86-64 with the above error. From this I would assume that qemux86 does not invoke repo2solve.sh? (note that in order to have /var/cache/zypp/raw/repo you need to run 'zypper refresh' and the repository name in this is case "repo", added using 'zypper addrepo [url] repo') Hope this helps. /Cornel
Reproduced on branch "danny": commit: 86c9aa8081f107420cd3763d0566d779daddc2b1 Date: Wed Oct 3 11:01:51 2012 -0700 image: core-image-sato-qemuarm
Potential release note candidate for 1.3. We are replacing zypper in the next release cycle.
Note, we're still discussing it, but at present we are planning on replacing zypper in the near future. (It's important to state that it's still under discussion, as this has not been finalized.)
Hi all , Same scenario even i also tested . in my environment its working fine. build : http://autobuilder.yoctoproject.org/pub/nightly/20121003-4/ root@qemux86-64:~# zypper addrepo http://192.168.7.1/yoctorpmrepo zypper_t99 Adding repository 'zypper_t99' [done] Repository 'zypper_t99' successfully added Enabled: Yes Autorefresh: No URI: http://192.168.7.1/yoctorpmrepo root@qemux86-64:~# zypper refresh Retrieving repository 'zypper_t99' metadata [\] File 'repomd.xml' from repository 'zypper_t99' is unsigned, continue? [yes/no] (no): yes Retrieving repository 'zypper_t99' metadata [done] Building repository 'zypper_t99' cache [done] All repositories have been refreshed. root@qemux86-64:~# thanks veera
Hello veera, What is the content of your /yoctorpmrepo folder? I have investigated the issue and it seems to be related to the rpm repo structure and configuration files. Also can you please use http://autobuilder.yoctoproject.org/pub/nightly/20121003-4/rpm/ as your repo URL? "zypper addrepo http://autobuilder.yoctoproject.org/pub/nightly/20121003-4/rpm/ zypper_t99" Thank you
Zypper has now been replaced by Smart for RPM, so this shouldn't be an issue anymore. Can we mark this one as RESOLVED INVALID?
We're doing SMART not zypper any more
This was reported for denzil that uses zypper.