Bug 2743 - Useradd command fails after 10 retries with 1.1.2 20120630 build
Summary: Useradd command fails after 10 retries with 1.1.2 20120630 build
Status: RESOLVED FIXED
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: core (show other bugs)
Version: 1.1.2
Hardware: x86 Multiple
: Medium normal
Target Milestone: 1.1.2
Assignee: Robert Yang
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2012-07-12 06:37 UTC by Yi Zhao
Modified: 2013-03-06 02:27 UTC (History)
9 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yi Zhao 2012-07-12 06:37:48 UTC
Tree/Branch: poky/edison
Commit: 8886aee5b9741c05886994967d9ecf420331c600

This issue is same as bug 2218 and fixed in 1.2. Seems the patch also need to be merged into edison tree.

http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=0923ee40ae59133c91a95e0727eb1ab95aca13b8

Steps:
Following the wiki page: https://wiki.yoctoproject.org/wiki/PAM_Integration
to build a image with PAM support. Image do_rootfs failed:
#################
| libical                     ##################################################
| libpcre0                    ##################################################
| libattr1                    ##################################################
| --
| WARNING: useradd command did not succeed. Retrying...
| WARNING: useradd command did not succeed. Retrying...
| WARNING: useradd command did not succeed. Retrying...
| WARNING: useradd command did not succeed. Retrying...
| WARNING: useradd command did not succeed. Retrying...
| ERROR: tried running useradd command 10 times without success, giving up
| xserver-nodm-init           ##################################################
|  Adding system startup for /buildarea2/yzhao-test/poky-build/build-pam/tmp/work/qemuarm-poky-linux-gnueabi/core-image-sato-1.0-r0/rootfs/etc/init.d/xserver-nodm.
| xrandr                      ##################################################
| update-rc.d                 ##################################################
| sysvinit-pidof              ##################################################
| 
| ERROR: Function 'do_rootfs' failed (see /buildarea2/yzhao-test/poky-build/build-pam/tmp/work/qemuarm-poky-linux-gnueabi/core-image-sato-1.0-r0/temp/log.do_rootfs.1120 for further information)
################
Comment 1 Joshua Lock - Disabled 2012-07-13 16:00:18 UTC
Is this only when enabling the PAM integration?

IIRC I avoided that patch as it's not a clean cherry-pick, the RPM package back-end changed quite a lot in 1.2

I'll start working on a fix for this issue on Monday.
Comment 2 Yi Zhao 2012-07-16 04:45:20 UTC
(In reply to comment #1)
> Is this only when enabling the PAM integration?

Now I can only reproduce this issue when enabling PAM. Just add one line in local.conf:

DISTRO_FEATURES_append = " pam"

> 
> IIRC I avoided that patch as it's not a clean cherry-pick, the RPM package
> back-end changed quite a lot in 1.2
> 
> I'll start working on a fix for this issue on Monday.
Comment 3 Saul Wold 2012-08-31 21:46:07 UTC
Is this similar to 3073?
Comment 4 Robert Yang 2012-09-02 07:43:57 UTC
(In reply to comment #3)
> Is this similar to 3073?

Not very sure currently, need more investigation.
Comment 5 Robert Yang 2012-09-04 11:41:34 UTC
This is not similar to 3073, and 1.3 doesn't have this problem, so change its milestone to 1.1.2
Comment 6 liang li 2012-09-05 02:53:58 UTC
(In reply to comment #5)
> This is not similar to 3073, and 1.3 doesn't have this problem, so change
> its milestone to 1.1.2

it means bug 3047.
Comment 7 Matthew McClintock 2013-02-14 18:55:28 UTC
Autobuilder is now seeing these issues...

-M
Comment 8 Richard Purdie 2013-02-14 21:13:39 UTC
(In reply to comment #7)
> Autobuilder is now seeing these issues...

I think those were from the pseudo update and have been resolved now...
Comment 9 Robert Yang 2013-03-06 02:27:57 UTC
See the comments from Richard, this has been fixed now.