Bug 4554 - Qemu could not startup with 20130521-1 image via UNFS for any architecture
Summary: Qemu could not startup with 20130521-1 image via UNFS for any architecture
Status: VERIFIED INVALID
Alias: None
Product: Meta-yocto
Classification: Build System, Metadata & Runtime
Component: configuration (show other bugs)
Version: unspecified
Hardware: x86 Multiple
: Undecided normal
Target Milestone: ---
Assignee: Saul Wold
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2013-05-24 10:57 UTC by Codrin Pruteanu
Modified: 2013-05-29 13:28 UTC (History)
2 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: ---


Attachments
Kernel panic when running qemu with nightly build 20130521-1 (19.52 KB, text/plain)
2013-05-24 10:57 UTC, Codrin Pruteanu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Codrin Pruteanu 2013-05-24 10:57:57 UTC
Created attachment 1223 [details]
Kernel panic when running qemu with nightly build 20130521-1

Branch: poky/master
Git rev: 176a46b088135f2891983bb8540bc45389341d90

steps:
1. download qemuarm images from http://autobuilder.yoctoproject.org/pub/nightly/20130516-3/machines/qemu/qemux86-64/core-image-minimal-qemux86-64-20130516210211.rootfs.tar.bz2

2. this image could not bootup via UNFS (both minimal and sato-sdk images)

log:
source /home/codrin/poky/1.4+snapshot/environment-setup-x86_64-poky-linux;
runqemu qemux86-64 /home/codrin/work/20130521-1/adt-installer/download_image/bzImage-qemux86-64.bin /home/codrin/work/20130521-1/adt-installer/test-yocto/x86_64

Continuing with the following log file:
.....
VFS: Unable to mount root fs via NFS, trying floppy

FS: Cannot open root device "nfs" or unknown-block(2,0): error -6
Please append a correct "root=" boot option; here are the available partitions:
1600         4194302 hdc  driver: ide-cdrom
VFS: Unable to mount root fs on unknown-block(2,0)
User configuration error - no valid root filesystem found
Kernel panic - not syncing: Invalid configuration from end user prevents continuing
Pid: 1, comm: swapper/0 Not tainted 3.8.11-yocto-standard #1
Call Trace:
 [<ffffffff8166f57d>] panic+0xc2/0x1ba
 [<ffffffff8166f712>] ? printk+0x67/0x69
 [<ffffffff81cc40c5>] mount_block_root+0x220/0x238
 [<ffffffff81cc42ed>] mount_root+0xf1/0xfa
 [<ffffffff81cc4462>] prepare_namespace+0x16c/0x1a4
 [<ffffffff81cc3d69>] kernel_init_freeable+0x206/0x214
 [<ffffffff81cc35a3>] ? do_early_param+0x88/0x88
 [<ffffffff81661fb0>] ? rest_init+0x80/0x80
 [<ffffffff81661fbe>] kernel_init+0xe/0x180
 [<ffffffff8167f8dc>] ret_from_fork+0x7c/0xb0
 [<ffffffff81661fb0>] ? rest_init+0x80/0x80
general protection fault: fff2 [#1] PREEMPT SMP
Comment 1 Codrin Pruteanu 2013-05-29 13:23:25 UTC
It seems that it was a firewall related issue: when pinging from host to qemu, nfsd wouldn't start until receiving reply from guest.
After disabling the firewall filter, quemu mounted the nfs root file system from target.
Comment 2 Codrin Pruteanu 2013-05-29 13:28:00 UTC
Verified.