Bug 5287 - Tar failed occasionally during the nativesdk toolchain build
Summary: Tar failed occasionally during the nativesdk toolchain build
Status: RESOLVED DUPLICATE of bug 4757
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: core (show other bugs)
Version: 1.5
Hardware: x86 Multiple
: Medium normal
Target Milestone: 1.5.1
Assignee: Saul Wold
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2013-09-30 06:25 UTC by LiRongQing
Modified: 2013-10-31 17:49 UTC (History)
4 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: Don't know


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description LiRongQing 2013-09-30 06:25:52 UTC
1. Zhenhua reported this building failure on 27 Mar 2013, Seems no fix is written for it, and we are meeting this issue occasionally, about 5 percents.

http://comments.gmane.org/gmane.comp.handhelds.openembedded.core/35286


2. Our failure log is:

tar: ./sysroots/x86_64-wrlinuxsdk-linux/var/lib/rpm/__db.002: file changed as we read it
WARNING: /home/nxadm/nx/ala-blade15.1/builds-2013-08-12-170139/qemuarma9_core/bitbake_build/tmp/work/qemuarma9-wrs-linux-gnueabi/wrlinux-image-glibc-core/1.0-r2/temp/do_populate_sdk/run.do_populate_sdk.tar_sdk.28250:109 exit 1 from
tar --owner=root --group=root -cj --file=/home/nxadm/nx/ala-blade15.1/builds-2013-08-12-170139/qemuarma9_core/bitbake_build/tmp/deploy/sdk/wrlinux-6.0.0.0-eglibc-x86_64-qemuarma9-wrlinux-image-glibc-core-sdk.tar.bz2 .
DEBUG: Python function do_populate_sdk finished
ERROR: Function failed: tar_sdk (log file is located at /home/nxadm/nx/ala-blade15.1/builds-2013-08-12-170139/qemuarma9_core/bitbake_build/tmp/work/qemuarma9-wrs-linux-gnueabi/wrlinux-image-glibc-core/1.0-r2/temp/do_populate_sdk/log.do_populate_sdk.28250)
Comment 1 Richard Purdie 2013-09-30 21:38:07 UTC
Which version of Linux is this on? We have strong suspicions this happens with broken kernels and this is just a symptom of that. Upgrade your system to a kernel which doesn't corrupt filesystem data.
Comment 2 LiRongQing 2013-10-08 02:10:40 UTC
I saw it happened on CentOS 5.9 and RedHat 5.5;

It is hard to upgrade many servers, Could we write a workaround?
Comment 3 Zhenhua Luo 2013-10-16 06:06:19 UTC
Bug 4757 reports the same issue.
Comment 4 Richard Purdie 2013-10-31 17:49:11 UTC
This is a duplicate bug, marking as such.

*** This bug has been marked as a duplicate of bug 4757 ***