Bug 540 - rpm version compare works incorrectly
Summary: rpm version compare works incorrectly
Status: VERIFIED INVALID
Alias: None
Product: Meta-yocto
Classification: Build System, Metadata & Runtime
Component: meta-yocto (show other bugs)
Version: 0.9
Hardware: x86 Multiple
: Low normal
Target Milestone: 1.0 M1
Assignee: Qing He
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2010-11-16 19:33 UTC by Ke Yu
Modified: 2010-12-21 06:07 UTC (History)
5 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified: Program Management
Documentation change: ---


Attachments
cairo: upgrade from 1.8.10 to 1.10.0 (1.88 KB, text/plain)
2010-11-16 19:35 UTC, Ke Yu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ke Yu 2010-11-16 19:33:16 UTC
When I upgrade cairo from 1.8.10 to 1.10.0, and doing poky-image-sato do_rootfs,  the zypper will report:

"
| Processing zypper...
| error: Failed dependencies:
|       libcairo2 >= 1.8.10 is needed by screenshot-0.0+svnr292-r0.i586
|       libcairo2 >= 1.8.10 is needed by lttng-viewer-0.12.35-r0.i586
|       libcairo2 >= 1.8.10 is needed by gtk+-2.20.1-r1.i586
|       libcairo2 >= 1.8.10 is needed by pango-1.28.0-r0.i586
|       libcairo2 >= 1.8.10 is needed by libowl0-0.0+svnr408-r6.i586
|       libcairo2 >= 1.8.10 is needed by libfm-0.1.12-r0.i586
|       libcairo2 >= 1.8.10 is needed by librsvg-2-2-2.26.3-r0.i586
|       libcairo2 >= 1.8.10 is needed by libowl-av0-0.0+svnr398-r4.i586
|       libcairo2 >= 1.8.10 is needed by libwebkitgtk-1.0-0-1.3.2+svnr62027-r0.i586
|       libcairo2 >= 1.8.10 is needed by lttng-viewer-dev-0.12.35-r0.i586
|       libcairo-dev is needed by pango-dev-1.28.0-r0.i586
|       libcairo-dev is needed by gtk+-dev-2.20.1-r1.i586
"

cairo 1.10.0 should actually meet the requirement of >=1.8.10, so looks zypper does not correctly compare the version.

if i rebuild those recipes, i.e. increase the PR of the recipes (screenshot, lttng-viewer...) , and build again, the error disappear. the rpm spec becomes:  
Requires: cairo >= 1.10.0

Reproduce step:
1. build poky-image-sato from scratch with poky 4.0
# git checkout laverne-4.0
# . poky-init-build-env
# bitbake poky-image-sato

2. apply the attached patch to upgrade cairo, and build poky-image-sato again
# patch -p1 < cairo.patch
# bitbake poky-image-sato

3. the error will show out.
Comment 1 Ke Yu 2010-11-16 19:35:16 UTC
Created attachment 68 [details]
cairo: upgrade from 1.8.10 to 1.10.0

add patch of upgrade cairo
Comment 2 Ke Yu 2010-12-08 22:43:28 UTC
it is not caused by rpm, instead, it is due to cairo renaming from libcairo2 to cairo2 during the upgrade. so mark this bug as invalid.
Comment 3 Ke Yu 2010-12-08 23:23:38 UTC
verified