Bug 6500 - no permissions when first deploying an app to QEMU and running it
Summary: no permissions when first deploying an app to QEMU and running it
Status: RESOLVED WORKSFORME
Alias: None
Product: Eclipse Plugin
Classification: Yocto Project Subprojects
Component: eclipse-plugin (show other bugs)
Version: 1.7
Hardware: x86 Multiple
: Medium normal
Target Milestone: 1.7
Assignee: David Reyna
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2014-07-02 14:14 UTC by Alexandru Georgescu
Modified: 2014-10-22 14:07 UTC (History)
7 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: Regression (Found by QA test)
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments
error messages in eclipse (162.12 KB, image/png)
2014-07-02 14:16 UTC, Alexandru Georgescu
no flags Details
yocto project settings (239.12 KB, image/png)
2014-07-02 14:16 UTC, Alexandru Georgescu
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandru Georgescu 2014-07-02 14:14:39 UTC
poky: 68824d9b8f6e290da078383316b3f4b732585f2b
eclipse-poky-kepler: 4a167fd662262ebdaa3cf0d332ac0debb52d7904
AB link: http://autobuilder.yoctoproject.org/pub/releases/yocto-1.7_M1.rc1



DESCRIPTION:
When first deploying an app with Eclipse to a running QEMU (using SSH connection) sometimes (not 100%) sh don't have permissions to run.

STEPS TO REPRODUCE:
1. Setup an eclipse environment running headless build and installing the eclipse plugin (Kepler) from the AB.
2. As Sysroot, toolchain and QEMU you can either use adt-installed qemu (this means that the qemu will boot via NFS - was downloaded the tar.gz version), it's not an *.ext3 booted image (didn't test with it yet)
3. Create a GTK autotools project (in my case but happened with a simple C autotools project).
4. Reconfigure the project
5. Build the project
6. Power on qemu from Eclipse Plugin 
7. Setup a new SSH connection within Eclipse and deploy the app using the Run Configurations menu.
8. In Run configurations, make sure you select the connection created in #7 and the other settings, like exporting the display (more details in the attached print_screen_2)
9. Press RUN
10. Try again step #9

EXPECTED RESULTS:
9. App deploys to QEMU and runs.
10. App deploys to QEMU and runs.

ACTUAL RESULTS:
9: Some error permission happens:

Last login: Wed Jul  2 13:59:08 2014 from 192.168.7.7
echo $PWD'>'
export DISPLAY=:0.0;/home/root/jkalkjadkljaklsjdlka;exit
root@qemux86:~# echo $PWD'>'
/home/root>
root@qemux86:~# export DISPLAY=:0.0;/home/root/jkalkjadkljaklsjdlka;exit
-sh: /home/root/jkalkjadkljaklsjdlka: Permission denied
logout

10. App deploys to QEMU and runs!

NOTE!!!

Note that attempting the second time this works.
Comment 1 Alexandru Georgescu 2014-07-02 14:16:23 UTC
Created attachment 2026 [details]
error messages in eclipse
Comment 2 Alexandru Georgescu 2014-07-02 14:16:43 UTC
Created attachment 2027 [details]
yocto project settings
Comment 3 Alexandru Georgescu 2014-07-02 14:18:52 UTC
I'm not sure but this might be related to: bug 6484
Comment 4 Mihail Stanciu 2014-10-22 14:07:58 UTC
Unable to reproduce.
Noticed similar behaviour if initial configuration lacked a proper entry for "Remote Absolute File Path for C/C++ Application" text box.
Suspect initial error was due to erroneous entry for above mentioned text box.