Bug 6716 - ASPM gets disabled by kernel
Summary: ASPM gets disabled by kernel
Status: RESOLVED FIXED
Alias: None
Product: MinnowBoard MAX Firmware
Classification: Hardware Platforms
Component: minnowboard-uefi-firmware (show other bugs)
Version: 2C A1
Hardware: MinnowBoard Max Multiple
: Medium normal
Target Milestone: Production Release
Assignee: Darren Hart
QA Contact:
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2014-09-12 17:38 UTC by Marcel Holtmann
Modified: 2014-11-07 02:25 UTC (History)
5 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Holtmann 2014-09-12 17:38:52 UTC
It seems that ASPM gets disabled due to an invalid UUID:

[    0.734472] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.735321] \_SB_.PCI0:_OSC invalid UUID
[    0.735355] _OSC request data:1 1f 0 
[    0.735378] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM

This also has some later impact with the Ethernet controller:

[   13.399731] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   13.399768] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control

Is ASPM suppose to work with these boards?
Comment 1 Darren Hart 2014-09-12 20:21:02 UTC
I hadn't made the connection to the Ethernet driver before this, thanks for that. We had been experiencing some issues with the Ethernet driver during resume that appeared to be resolved in a later kernel, but perhaps this impacted it.

I need to dig into ASPM to know if this is supported. I know we support S3 suspend/resume on this SoC, I'm just not sure exactly what role ASPM plays.
Comment 2 Darren Hart 2014-09-12 20:25:28 UTC
This was also reported here:
https://lists.debian.org/debian-kernel/2014/04/msg00022.html

Some initial research confirms ASPM is indeed supported on the SoC. Leaving this assigned to Tim to investigate the _OSC invalid UUID error.
Comment 3 Darren Hart 2014-11-06 23:24:31 UTC
I no longer see these errors with Linux 3.17.1 nor 3.18-rc3.

I have not seen a statement about a fix in the firmware, it's possible this was a kernel fix.

Tim, has anything changed in the firmware?

I'm prepared to close this as resolved, but would like to here back from Tim first. Assigning to Tim and marking NEEDINFO.
Comment 4 David_Wei 2014-11-07 02:19:53 UTC
Hi Darren,

0.74 binary release have updated _OSC to properly represent support to ASPM and other native PCIe capability. Sorry that we forget to update you in time.

I will change to owner to you on behalf of Tim so that you can review it and then close it.
Comment 5 Darren Hart 2014-11-07 02:25:09 UTC
Thanks David, I verified this afternoon. Marking as closed.