Bug 8588 - OpenSUSE taps configuration failure
Summary: OpenSUSE taps configuration failure
Status: VERIFIED NOTABUG
Alias: None
Product: OE-Core
Classification: Build System, Metadata & Runtime
Component: core (show other bugs)
Version: 2.0
Hardware: x86 Multiple
: Medium normal
Target Milestone: 2.1
Assignee: Cristian Iorga
QA Contact: Mihail Stanciu
URL:
Whiteboard:
Depends on:
Blocks:
 
Reported: 2015-10-27 12:37 UTC by Mihail Stanciu
Modified: 2015-11-06 14:07 UTC (History)
5 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: Regression (Used to work)
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihail Stanciu 2015-10-27 12:37:48 UTC
Tested on master: 505a82673ac2487df5ea343a6422c2fc47018831
OS affected: OpenSUSE 13.2

All sanity tests failed on OpenSUSE AB with following error:


| qemu-system-arm: -net tap,vlan=0,ifname=tap0,script=no,downscript=no: could not configure /dev/net/tun (tap0): Operation not permitted
| Releasing lockfile of preconfigured tap device 'tap0'
| stty: standard input: Inappropriate ioctl for device
| stty: standard input: Inappropriate ioctl for device

All taps are pre-generated on system startup with runqemu-gen-tapdevs script.
Comment 1 Cristian Iorga 2015-11-02 09:02:38 UTC
Investigation started.
Comment 2 Mihail Stanciu 2015-11-02 12:33:45 UTC
Possible root cause:
Taps were being created by default as belonging to user autobuilder, but the group used in creation did not exist. Modified tap creation script to use the default autobuilder group for OpenSUSE (users - gid 100) and the problem seems to have gone away.

Currently re-running a full test pass on this machine.
Will update further once run is complete.
Comment 3 Mihail Stanciu 2015-11-06 14:05:32 UTC
(In reply to comment #2)
> Possible root cause:
> Taps were being created by default as belonging to user autobuilder, but the
> group used in creation did not exist. Modified tap creation script to use
> the default autobuilder group for OpenSUSE (users - gid 100) and the problem
> seems to have gone away.
> 
> Currently re-running a full test pass on this machine.
> Will update further once run is complete.

This has fixed the problem.
Marking as NOTABUG.
Comment 4 Mihail Stanciu 2015-11-06 14:07:08 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Possible root cause:
> > Taps were being created by default as belonging to user autobuilder, but the
> > group used in creation did not exist. Modified tap creation script to use
> > the default autobuilder group for OpenSUSE (users - gid 100) and the problem
> > seems to have gone away.
> > 
> > Currently re-running a full test pass on this machine.
> > Will update further once run is complete.
> 
> This has fixed the problem.
> Marking as NOTABUG.

Verified as per above.