Bug 9335 - [Autobuilder] Add support for display bitbake log errors in buildbot page
Summary: [Autobuilder] Add support for display bitbake log errors in buildbot page
Status: CLOSED FIXED
Alias: None
Product: AutoBuilder
Classification: Infrastructure
Component: autobuilder (show other bugs)
Version: 2.1
Hardware: x86 Multiple
: Medium enhancement
Target Milestone: Future
Assignee: Unassigned
QA Contact:
URL:
Whiteboard: Was Bill Randle
Depends on:
Blocks:
 
Reported: 2016-03-23 17:58 UTC by Aníbal Limón
Modified: 2019-12-22 21:32 UTC (History)
8 users (show)

See Also:
OS type for building Yocto: ---
Type of Regression: ---
Verified:
Documentation change: No (bug/feature does not impact docs)


Attachments
main build page (249.25 KB, image/jpeg)
2016-03-23 17:58 UTC, Aníbal Limón
no flags Details
log detail page (680.25 KB, image/jpeg)
2016-03-23 17:59 UTC, Aníbal Limón
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aníbal Limón 2016-03-23 17:58:23 UTC
Created attachment 3060 [details]
main build page

It will be good to access bitbake error logs trough the buildbot web interface, i did an implementation before to see how it looks review the attachment.

Details:

I worked on the AB code for publish test logs, the patch [1] had the problem of access to workers logs because is using open call directly from controller and it will fail because the patch only exists in the worker.

So the problem to solve is how to access worker logs, i decided to use a
HTTP server because the implementation for get logs is in
commandComplete callback in ShellCommand at this stage we can't execute
another step like FileDownload also we can't add more steps dynamically
after the current one (a function exists but our buildbot version seems
to be old).

Now the worker could start a Twisted HTTP Server for serve files. there
is a variable in config/autobuilder.conf for enable the server. Then if
bitbake command fails and Worker http server is enabled it parses the
log paths and request trough HTTP the log file for dump it to buildbot
logs. There are a limitation about the builderslave name need to be the
host name of the machine, this limitation don't affect us since our AB
infrastructure uses hostnames as buildslave names. [2]

[1] https://lists.yoctoproject.org/pipermail/yocto/2016-February/028822.html
[2] http://git.yoctoproject.org/cgit/cgit.cgi/yocto-autobuilder/log/?h=contrib/alimon/devel_http
Comment 1 Aníbal Limón 2016-03-23 17:59:17 UTC
Created attachment 3061 [details]
log detail page
Comment 2 Richard Purdie 2016-07-18 21:37:04 UTC
Setting up http servers onto the worker machines makes me nervous from a security perspective. I know we have done this before so we could more easily access files in TMPDIR but Michael ended up disabling it. We need to check to see if this would be acceptable to him from a security perspective (even if firewalled).

Moving to Future as we probably have more pressing issues right now.
Comment 3 Armin Kuster 2019-12-22 21:31:50 UTC
I think we are doing this via the wiki page.

AB has been redo so I think this is fixed.
Comment 4 Armin Kuster 2019-12-22 21:32:33 UTC
If you think this is closed in error, please create a new bug stating your case.