Bug 1252

Summary: Non-root user can't perform crontab command
Product: [Runtime] Installation Reporter: Wenzong.Fan <wenzong.fan>
Component: InstallationAssignee: Wenzong.Fan <wenzong.fan>
Status: VERIFIED FIXED QA Contact:
Severity: normal    
Priority: Medium CC: kevin.tian, liang.li2, liangliang.wang, sgw, Xiaofeng.yan, yi.zhao
Version: unspecified   
Target Milestone: 1.1 M3   
Hardware: x86   
OS: Multiple   
Whiteboard: Has been Merged
OS type for building Yocto: --- Type of Regression: ---
Verified: Documentation change: ---

Description Wenzong.Fan 2011-07-18 00:02:01 UTC
Tested on a lsb images which enabled pam for crond.

Non-root user can't perform command 'crontab -l/-e'.

The error logs from /var/log/auth.log:
Jul 12 02:36:14 qemux86 unix_chkpwd[768]: could not obtain user info (test-pam)

root cause:
unix_chkpwd can't get user info from '/etc/shadow' because it has incorrect permission settings:

root@qemux86:~# ll /etc/shadow
-r-------- 1 root root 1090 Jul 14 05:29 /etc/shadow

On a ubuntu host it is:
-rw-r----- 1 root shadow 1389 2011-07-07 18:04 /etc/shadow
Comment 1 Saul Wold 2011-07-18 09:28:36 UTC
*** Bug 1253 has been marked as a duplicate of this bug. ***
Comment 2 Saul Wold 2011-07-18 15:10:30 UTC
May require setting setuid bit for non-pam crontab binary
Comment 3 Wenzong.Fan 2011-08-24 19:30:09 UTC
Merged
Comment 4 Wenzong.Fan 2011-08-28 19:23:03 UTC
The commit 6ba3b6ba9b8587791e392bf3542403ab33ca9ad3
Comment 5 Yi Zhao 2011-08-29 00:23:31 UTC
Verified with poky master branch.
git info: 6c2b7beac3cd23ed44bd3e195c6360a0932876bf